<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US"> <!--<![endif]--><head><style id="rocket-critical-css">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</style><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://linux4one.com/xmlrpc.php" /><title>How to Find or Search a Word in Vim or Vi Text Editor | Linux4one</title> <script type="text/javascript">var trackScrolling=true;
var trackScrollingPercentage=true;
var ScrollingPercentageNumber=25;
var stLogInterval=30*1000;
var cutOffTime=900;
var trackNoEvents=false;
var trackNoMaxTime=false;
var docTitle='How to Find or Search a Word in Vim or Vi Text Editor';</script> <meta property="og:image" content="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor.jpg" /><link rel="icon" type="image/png" href="https://linux4one.com/wp-content/uploads/2019/02/favicon-32x32.png"><meta name="description" content="Vim is a popular text editor that comes preinstalled on macOS, Linux Distros and BSD Like operating systems. In this tutorial, you are going to learn How to Find or Search a Word in Vim or Vi Text Editor."/><link rel="canonical" href="https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to Find or Search a Word in Vim or Vi Text Editor | Linux4one" /><meta property="og:description" content="Vim is a popular text editor that comes preinstalled on macOS, Linux Distros and BSD Like operating systems. In this tutorial, you are going to learn How to Find or Search a Word in Vim or Vi Text Editor." /><meta property="og:url" content="https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/" /><meta property="og:site_name" content="Linux4one" /><meta property="article:section" content="Linux" /><meta property="article:published_time" content="2020-01-02T13:30:40+05:30" /><meta property="article:modified_time" content="2020-01-02T13:31:56+05:30" /><meta property="og:updated_time" content="2020-01-02T13:31:56+05:30" /><meta property="og:image" content="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor.jpg" /><meta property="og:image:secure_url" content="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor.jpg" /><meta property="og:image:width" content="750" /><meta property="og:image:height" content="350" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Vim is a popular text editor that comes preinstalled on macOS, Linux Distros and BSD Like operating systems. In this tutorial, you are going to learn How to Find or Search a Word in Vim or Vi Text Editor." /><meta name="twitter:title" content="How to Find or Search a Word in Vim or Vi Text Editor | Linux4one" /><meta name="twitter:image" content="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor.jpg" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://linux4one.com/#website","url":"https://linux4one.com/","name":"Linux4one","potentialAction":{"@type":"SearchAction","target":"https://linux4one.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/#primaryimage","url":"https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor.jpg","width":750,"height":350,"caption":"How to Find or Search a Word in Vim or Vi Text Editor"},{"@type":"WebPage","@id":"https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/#webpage","url":"https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/","inLanguage":"en-US","name":"How to Find or Search a Word in Vim or Vi Text Editor | Linux4one","isPartOf":{"@id":"https://linux4one.com/#website"},"primaryImageOfPage":{"@id":"https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/#primaryimage"},"datePublished":"2020-01-02T13:30:40+05:30","dateModified":"2020-01-02T13:31:56+05:30","author":{"@id":"https://linux4one.com/#/schema/person/c1e0bc1d819d179c9dcb01a2f44c4606"},"description":"Vim is a popular text editor that comes preinstalled on macOS, Linux Distros and BSD Like operating systems. In this tutorial, you are going to learn How to Find or Search a Word in Vim or Vi Text Editor."},{"@type":["Person"],"@id":"https://linux4one.com/#/schema/person/c1e0bc1d819d179c9dcb01a2f44c4606","name":"root_rahul","image":{"@type":"ImageObject","@id":"https://linux4one.com/#authorlogo","url":"https://secure.gravatar.com/avatar/9594f38dca2f014bcc00e5c1ac5415d0?s=96&d=mm&r=g","caption":"root_rahul"},"sameAs":[]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Linux4one &raquo; Feed" href="https://linux4one.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Linux4one &raquo; Comments Feed" href="https://linux4one.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Linux4one &raquo; How to Find or Search a Word in Vim or Vi Text Editor Comments Feed" href="https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='preload' id='wp-block-library-css'  href='https://linux4one.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='contact-form-7-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/contact-form-7/includes/css/styles-438961790fb6a475846385ef6ca3a9c9.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='crp-style-rounded-thumbs-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/contextual-related-posts/css/default-style-a2b72e907f8cb004a1912b9d76ee4671.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='crp-style-rounded-thumbs-inline-css' type='text/css'>.crp_related a{width:150px;height:150px;text-decoration:none}.crp_related img{max-width:150px;margin:auto}.crp_related .crp_title{width:100%}</style><link data-minify="1" rel='preload' id='copy-the-code-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/copy-the-code/assets/css/copy-the-code-92d749726da878bd0cfab6125798a1fe.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='saswp-collection-front-css-css'  href='https://linux4one.com/wp-content/plugins/schema-and-structured-data-for-wp/admin_section/css/collection-front.min.css?ver=1.9.17' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='toc-screen-css'  href='https://linux4one.com/wp-content/plugins/table-of-contents-plus/screen.min.css?ver=1509' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='td-plugin-newsletter-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/td-newsletter/style-2eea3d533a39f33f697d7d48c81f422e.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='td-plugin-multi-purpose-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/td-composer/td-multi-purpose/style-6e90ec1cf17f68e61e0b9180c8c38b66.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%7CRubik%3A400%7CMontserrat%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.7.2' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='wp_review-style-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/wp-review/public/css/wp-review-db089dc082eb067e3233a2967efc9a1e.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='td-theme-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/themes/Newspaper/style-9afd48c3b779f68531abb291df65a1f8.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='td-theme-inline-css' type='text/css'>@media (max-width:767px){.td-header-desktop-wrap{display:none}}@media (min-width:767px){.td-header-mobile-wrap{display:none}}</style><link data-minify="1" rel='preload' id='td-legacy-framework-front-style-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main-7096004acac4c7bc6eeb8856f3f610ce.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link data-minify="1" rel='preload' id='tdb_front_style-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front-d42b5d47e57d303116b523ab02d9fc3f.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/schema-and-structured-data-for-wp/admin_section/js/collection-front.min.js?ver=1.9.17' defer></script> <link rel='https://api.w.org/' href='https://linux4one.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linux4one.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linux4one.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://linux4one.com/?p=3523' /><meta name="generator" content="Site Kit by Google 1.1.2" /><script data-ad-client="ca-pub-5763298617442226" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><style type="text/css">div#toc_container{width:100%}</style><script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//linux4one.com/?wordfence_lh=1&hid=E208A130D1F9BF38079A26BF3E18D7D0');</script><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--> <script>window.tdb_globals = {"wpRestNonce":"a565ce7069","wpRestUrl":"https:\/\/linux4one.com\/wp-json\/","permalinkStructure":"\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"origPostEditUrl":null};</script> <script>window.tdwGlobal = {"adminUrl":"https:\/\/linux4one.com\/wp-admin\/","wpRestNonce":"a565ce7069","wpRestUrl":"https:\/\/linux4one.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-5763298617442226",
enable_page_level_ads: true,
tag_partner: "site_kit"
});</script> <meta name="onesignal" content="wordpress-plugin"/> <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://linux4one.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '9ca03889-aa62-4288-bc49-9ba69e68905b';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Linux4one";
oneSignal_options['welcomeNotification']['message'] = "Thank you for subscribing";
oneSignal_options['path'] = "https://linux4one.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
              oneSignal_options['autoRegister'] = false;
              OneSignal.showHttpPrompt();
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script>  <script type="application/ld+json" class="saswp-schema-markup-output">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</script>  <script>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</script> <style>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</style> <script data-no-minify="1" async src="https://linux4one.com/wp-content/cache/busting/1/gtm-local.js"></script> <script>window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-133283091-3');</script> <style type="text/css" id="wp-custom-css">.td-boxed-layout .vc_row{background-color:#fff!important}pre{font-size:17px;font-weight:400;padding:14px 14px 14px 14px;background:#f4f7fc!important}pre:hover>.copy-the-code-button{opacity:1}.copy-the-code-button:hover{background:#38af3c!important}.copy-the-code-button{opacity:0;position:absolute!important;right:10px!important;top:10px!important;background:#38af3c!important;padding:0 10px!important;cursor:pointer!important;box-shadow:none!important;color:#ffffff!important;font-size:13px!important;font-weight:normal!important;border-radius:4px!important;text-transform:capitalize!important;border:none!important}#toc_container{background:#f4f7fc;border:none;padding:15px}#toc_container p.toc_title{text-align:left;font-size:24px}#toc_container a{text-decoration:none;text-shadow:none;font-size:18px;color:#111}.td-post-small-box a{color:#fff;border-radius:5px;border:none;background:#4CAF50;font-size:17px;display:block;float:left;margin-left:4px;line-height:18px;padding:7px 9px;height:35px}.td-post-small-box span{color:#fff;border-radius:5px;border:none;background:#333;font-size:17px;display:block;float:left;margin-left:4px;line-height:18px;padding:7px 9px;height:35px}.widget li{margin-left:1px}.td_module_6 .entry-title{font-size:16px;line-height:18px;font-weight:700}.td-module-thumb img{min-height:100%}.td-load-more-wrap a{font-weight:600;font-size:18px;color:#fff;background:#38af3c;border:none;border-radius:5px;padding:10px 25px}.td-load-more-wrap a:hover{background:#38af3c}.td-post-date time{font-size:13px}.item-details{position:relative;top:50%}.td-category-pulldown-filter{display:none}.td-category{height:40px!important}.entry-category a{border-radius:5px;padding:12px 10px!important;font-size:15px!important;font-weight:600}.pre_venv::before{content:"(venv) $ ";color:#838383}.pre_output::before{display:block;content:"Output";color:#838383;margin-bottom:.7rem}.related_distros{background-color:#060}.related_distros>p{padding:10px;color:#fff;font-weight:700}.related_distros>ul{padding:0;list-style:none}.related_distros>ul>li{display:inline-block;zoom:1;display:inline}.related_distros>ul>li>a{color:#fff;width:50%}.crp_title{font-family:merriweather-regular-webfont!important;font-size:16px}.crp_related_widget li{padding-top:5px;padding-bottom:5px;margin-bottom:10px;padding-left:10px;border-left:3px solid #4CAF50;border-bottom:1px solid #e1e1e1;line-height:25px}code,kbd,pre,samp{font-size:17px;background:#f4f7fc}.td-post-content ul{font-size:18px;margin-left:10px}.td-post-content li{font-size:18px;line-height:35px}.block-title{font-size:17px}</style><style>.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.sfHover>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>li>a:hover,.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,.tds-button2 .tdm-btn-text,.tds-button2 i,.tds-button5:hover .tdm-btn-text,.tds-button5:hover i,.tds-button6 .tdm-btn-text,.tds-button6 i,.tdm_block_list .tdm-list-item i,.tdm_block_pricing .tdm-pricing-feature i,.tdm-social-item i{color:#38af3c}.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>li>a:hover,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.sfHover>a,.tds-button1,.tds-button6:after,.tds-title2 .tdm-title-line:after,.tds-title3 .tdm-title-line:after,.tdm_block_pricing.tdm-pricing-featured:before,.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,.tds-progress-bar1 .tdm-progress-bar:after,.tds-progress-bar2 .tdm-progress-bar:after,.tds-social3 .tdm-social-item{background-color:#38af3c}.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-item>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>li>a:hover,.tdm-menu-active-style4 .tdm-header .sf-menu>.sfHover>a,.tds-button2:before,.tds-button6:before,.tds-progress-bar3 .tdm-progress-bar:after{border-color:#38af3c}.tdm-btn-style1{background-color:#38af3c}.tdm-btn-style2:before{border-color:#38af3c}.tdm-btn-style2{color:#38af3c}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #38af3c;-moz-box-shadow:0 2px 16px #38af3c;box-shadow:0 2px 16px #38af3c}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #38af3c;-moz-box-shadow:0 4px 26px #38af3c;box-shadow:0 4px 26px #38af3c}.tdm-header-style-1.td-header-wrap .td-header-top-menu-full,.tdm-header-style-1.td-header-wrap .top-header-menu .sub-menu,.tdm-header-style-2.td-header-wrap .td-header-top-menu-full,.tdm-header-style-2.td-header-wrap .top-header-menu .sub-menu,.tdm-header-style-3.td-header-wrap .td-header-top-menu-full,.tdm-header-style-3.td-header-wrap .top-header-menu .sub-menu{background-color:#020000}</style><style id="tdw-css-placeholder"></style><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body class="post-template-default single single-post postid-3523 single-format-standard how-to-find-or-search-a-word-in-vim-or-vi-text-editor global-block-template-1 td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" rel="nofollow" href="https://www.facebook.com/linux4one/?modal=admin_todo_tour" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" rel="nofollow" href="https://twitter.com/Linux4oneC" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-linux-container"><ul id="menu-linux" class="td-mobile-main-menu"><li id="menu-item-1252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-1252"><a href="https://linux4one.com/">Home</a></li><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11"><a href="https://linux4one.com/category/linux/">Linux</a></li><li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://linux4one.com/category/ubuntu/">Ubuntu</a></li><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://linux4one.com/category/centos/">CentOS</a></li><li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://linux4one.com/category/debian/">Debian</a></li><li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15"><a href="https://linux4one.com/category/linux-commands/">Linux Commands</a></li></ul></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://linux4one.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap "><div class="td-header-wrap tdm-header tdm-header-style-1 "><div class="td-header-menu-wrap-full td-container-wrap td_stretch_container"><div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search"><div class="td-container td-header-row td-header-main-menu"><div class="tdm-menu-btns-socials"><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://linux4one.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-menu"> <a class="td-main-logo" href="https://linux4one.com/"> <img src="https://linux4one.com/wp-content/uploads/2019/02/icon6.png" alt="Linux4one" title="Linux4one"/> <span class="td-visual-hidden">Linux4one</span> </a></div><div class="menu-linux-container"><ul id="menu-linux-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-1252"><a href="https://linux4one.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-11"><a href="https://linux4one.com/category/linux/">Linux</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14"><a href="https://linux4one.com/category/ubuntu/">Ubuntu</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-12"><a href="https://linux4one.com/category/centos/">CentOS</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-13"><a href="https://linux4one.com/category/debian/">Debian</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-15"><a href="https://linux4one.com/category/linux-commands/">Linux Commands</a></li></ul></div></div></div></div></div><div class="td-banner-wrap-full td-container-wrap "><div class="td-container-header td-header-row td-header-header"><div class="td-header-sp-recs"><div class="td-header-rec-wrap">  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header td_uid_1_5e16e16c69706_rand td_block_template_1 "><style>.td_uid_1_5e16e16c69706_rand.td-a-rec-img{text-align:left}.td_uid_1_5e16e16c69706_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:970px;height:250px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="3216691056"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="3216691056"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="3216691056"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="3216691056"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }</script> </div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-default "><div class="td-crumb-container"></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-3523" class="post-3523 post type-post status-publish format-standard has-post-thumbnail category-linux" itemscope itemtype="https://schema.org/Article"47><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="https://linux4one.com/category/linux/">Linux</a></li></ul><header class="td-post-title"><h1 class="entry-title">How to Find or Search a Word in Vim or Vi Text Editor</h1><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-01-02T19:00:40+00:00" >02/01/2020</time></span></div></header></div><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Flinux4one.com%2Fhow-to-find-or-search-a-word-in-vim-or-vi-text-editor%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=How+to+Find+or+Search+a+Word+in+Vim+or+Vi+Text+Editor&url=https%3A%2F%2Flinux4one.com%2Fhow-to-find-or-search-a-word-in-vim-or-vi-text-editor%2F&via=Linux4one"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/&amp;media=https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor.jpg&description=Vim is a popular text editor that comes preinstalled on macOS, Linux Distros and BSD Like operating systems. In this tutorial, you are going to learn How to Find or Search a Word in Vim or Vi Text Editor."><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=How+to+Find+or+Search+a+Word+in+Vim+or+Vi+Text+Editor %0A%0A https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/&title=How+to+Find+or+Search+a+Word+in+Vim+or+Vi+Text+Editor"><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content"><div class="td-post-featured-image"><figure><img width="750" height="350" class="entry-thumb" src="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor.jpg" srcset="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor.jpg 750w, https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-300x140.jpg 300w" sizes="(max-width: 750px) 100vw, 750px" alt="How to Find or Search a Word in Vim or Vi Text Editor" title="How to Find or Search a Word in Vim or Vi Text Editor"/><figcaption class="wp-caption-text">How to Find or Search a Word in Vim or Vi Text Editor</figcaption></figure></div><div id="toc_container" class="toc_wrap_left no_bullets"><p class="toc_title">Table of Contents</p><ul class="toc_list"><li><a href="#Finding_a_Word_in_Vim_or_Vi_in_Normal_Mode">Finding a Word in Vim or Vi in Normal Mode</a></li><li><a href="#Searching_Word_in_Vim_or_Vi_Examples">Searching Word in Vim or Vi Examples</a><ul><li><a href="#Search_a_Word_in_Vim_in_the_Forward_Direction">Search a Word in Vim in the Forward Direction</a></li><li><a href="#Search_a_Word_in_Vim_in_the_Backword_Direction">Search a Word in Vim in the Backword Direction</a></li></ul></li><li><a href="#How_to_Highlight_the_Words_When_Search">How to Highlight the Words When Search</a></li><li><a href="#Search_a_Current_Word_in_Vim_or_Vi">Search a Current Word in Vim or Vi</a></li><li><a href="#Conclusion">Conclusion</a></li></ul></div><h2>Find or Search a Word in Vim or Vi Text Editor</h2><p>Vim is a popular text editor that comes preinstalled on macOS, Linux Distros and BSD Like operating systems. Vim is a free and opensource text editor available today. Finding or searching a word is a frequent task that we often do. In this tutorial, you are going to learn How to Find or Search a Word in Vim or Vi Text Editor.</p><h3><span id="Finding_a_Word_in_Vim_or_Vi_in_Normal_Mode">Finding a Word in Vim or Vi in Normal Mode</span></h3><p>Follow below instructions to search a word in <a href="https://linux4one.com/how-to-save-a-file-in-vim-or-vi-and-quit-the-editor/">Vim</a>:</p><ol><li>If you are in any other mode then press the <code>Esc</code> key to come in Normal Mode.</li><li>Now, Vim supports search in two ways forward or backward. If you want to search forward then press <code>/</code> and type the word you want to search.</li><li>Otherwise, If you want to search backward then press <code>?</code> and type the text you want to search followed by <code>Enter</code> the key.</li><li>Now once you get the occurrence of the word. Then you can press <code>N</code> to get the next occurrence of the word in the forward direction.</li><li>Otherwise, you can press <code>n</code> to get the next occurrence of the word in a backward direction.</li></ol><h3><span id="Searching_Word_in_Vim_or_Vi_Examples">Searching Word in Vim or Vi Examples</span></h3><p>The following are the examples for searching words in <a href="https://www.vim.org/">Vim</a> or Vi.</p><h4><span id="Search_a_Word_in_Vim_in_the_Forward_Direction">Search a Word in Vim in the Forward Direction</span></h4><p>In this example, we are going to search word <code>systemd</code> inside the file <code>/etc/group</code>.</p><p>First, open <code>/etc/group</code> file using the following command:</p><pre>vim /etc/group</pre><p>Now press <code>Esc</code> key to come in normal mode.</p><p>Then press <code>/</code> key and enter the word <code>systemd</code> that we want to search and hit <code>Enter</code>:</p><pre>/systemd</pre><p><img class="size-full wp-image-3528" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Forward-Search.png" alt="&quot;How" data-lazy-srcset="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Forward-Search.png 812w, https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Forward-Search-300x189.png 300w, https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Forward-Search-768x484.png 768w" data-lazy-sizes="(max-width: 812px) 100vw, 812px" /><noscript><img class="size-full wp-image-3528" src="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Forward-Search.png" alt="&quot;How" srcset="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Forward-Search.png 812w, https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Forward-Search-300x189.png 300w, https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Forward-Search-768x484.png 768w" sizes="(max-width: 812px) 100vw, 812px" /></noscript></p>  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_inline td_uid_2_5e16e16c6b233_rand td_block_template_1 "><style>.td_uid_2_5e16e16c6b233_rand.td-a-rec-img{text-align:left}.td_uid_2_5e16e16c6b233_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="8327070019"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="8327070019"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="8327070019"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="8327070019"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }</script> </div><p>You can press <code>n</code> key to get the next occurrence in the backward direction. You can also press <code>N</code> key to get the next occurrence in the forward direction.</p><h4><span id="Search_a_Word_in_Vim_in_the_Backword_Direction">Search a Word in Vim in the Backword Direction</span></h4><p>In this example, we are going to search word <code>systemd</code> inside the file <code>/etc/group</code>.</p><p>First, open <code>/etc/group</code> file using the following command:</p><pre>vim /etc/group</pre><p>Now press <code>Esc</code> key to come in normal mode.</p><p>Then press <code>?</code> key and enter the word <code>systemd</code> that we want to search and hit <code>Enter</code>:</p><pre>?systemd</pre><p><img class="size-full wp-image-3526" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Backward-Search.png" alt="&quot;How" data-lazy-srcset="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Backward-Search.png 813w, https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Backward-Search-300x189.png 300w, https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Backward-Search-768x485.png 768w" data-lazy-sizes="(max-width: 813px) 100vw, 813px" /><noscript><img class="size-full wp-image-3526" src="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Backward-Search.png" alt="&quot;How" srcset="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Backward-Search.png 813w, https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Backward-Search-300x189.png 300w, https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor-Backward-Search-768x485.png 768w" sizes="(max-width: 813px) 100vw, 813px" /></noscript></p><p>You can press <code>n</code> key to get the next occurrence in the backward direction. You can also press <code>N</code> key to get the next occurrence in the forward direction.</p><h3><span id="How_to_Highlight_the_Words_When_Search">How to Highlight the Words When Search</span></h3><p>You can enable <a href="https://linux4one.com/how-to-turn-on-syntax-highlighting-in-vim-vi-editor/">highlight</a> words when searching by using the <code>:set hlsearch</code> command. To enable it, inside the normal mode of Vim enter the following command.</p><pre>:set hlsearch</pre><p>To stop highlighting words when search, enter the following command:</p><pre>:set !hlsearch</pre><h3><span id="Search_a_Current_Word_in_Vim_or_Vi">Search a Current Word in Vim or Vi</span></h3><p>The word where the cursor is located called the current word. To find current word follow below instructions:</p><ol><li>Move the cursor on the word that you want to search.</li><li>Now press <code>*</code> to search the word in the forward direction. You can also get the next occurrence by pressing the <code>*</code> key.</li><li>You can press <code>#</code> to search the word in the backword direction. You can also get the next occurrence by pressing the <code>#</code> key.</li></ol><h3><span id="Conclusion">Conclusion</span></h3><p>In this tutorial, you have learned How to Find or Search a Word in Vim or Vi Text Editor. If You have any queries regarding this please comment below.</p></div><footer><div class="td-post-source-tags"></div><div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Flinux4one.com%2Fhow-to-find-or-search-a-word-in-vim-or-vi-text-editor%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=How+to+Find+or+Search+a+Word+in+Vim+or+Vi+Text+Editor&url=https%3A%2F%2Flinux4one.com%2Fhow-to-find-or-search-a-word-in-vim-or-vi-text-editor%2F&via=Linux4one"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/&amp;media=https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor.jpg&description=Vim is a popular text editor that comes preinstalled on macOS, Linux Distros and BSD Like operating systems. In this tutorial, you are going to learn How to Find or Search a Word in Vim or Vi Text Editor."><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=How+to+Find+or+Search+a+Word+in+Vim+or+Vi+Text+Editor %0A%0A https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/&title=How+to+Find+or+Search+a+Word+in+Vim+or+Vi+Text+Editor"><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="">root_rahul</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="root_rahul"></span><meta itemprop="datePublished" content="2020-01-02T19:00:40+00:00"><meta itemprop="dateModified" content="2020-01-02T19:01:56+05:30"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://linux4one.com/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://linux4one.com/wp-content/uploads/2019/02/icon6.png"></span><meta itemprop="name" content="Linux4one"></span><meta itemprop="headline " content="How to Find or Search a Word in Vim or Vi Text Editor"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://linux4one.com/wp-content/uploads/2020/01/How-to-Find-or-Search-a-Word-in-Vim-or-Vi-Text-Editor.jpg"><meta itemprop="width" content="750"><meta itemprop="height" content="350"></span></footer></article><div class="comments" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-find-or-search-a-word-in-vim-or-vi-text-editor/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://linux4one.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div><div class="comment-form-input-wrap td-form-comment"><textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea><div class="td-warning-comment">Please enter your comment!</div></div><div class="comment-form-input-wrap td-form-author"> <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30"  aria-required='true' /><div class="td-warning-author">Please enter your name here</div></div><div class="comment-form-input-wrap td-form-email"> <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30"  aria-required='true' /><div class="td-warning-email-error">You have entered an incorrect email address!</div><div class="td-warning-email">Please enter your email address here</div></div><div class="comment-form-input-wrap td-form-url"> <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" /></div><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='3523' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="743f724634" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="189"/></p></form></div></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar">  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar td_uid_3_5e16e16c6bd8f_rand td_block_template_1 "><style>.td_uid_3_5e16e16c6bd8f_rand.td-a-rec-img{text-align:left}.td_uid_3_5e16e16c6bd8f_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="8310548715"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="8310548715"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="8310548715"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="8310548715"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }</script> </div><aside class="td_block_template_1 widget widget_widget_crp"><h4 class="block-title"><span>Related Posts</span></h4><div class="crp_related_widget"><ul><li><a href="https://linux4one.com/how-to-remove-docker-images-networks-containers-and-volumes/"    ><span class="crp_title">How to Remove Docker Images, Networks, Containers&hellip;</span></a></li><li><a href="https://linux4one.com/15-curl-command-examples-in-linux/"    ><span class="crp_title">17 Curl Command Examples in Linux</span></a></li><li><a href="https://linux4one.com/how-to-install-and-use-docker-on-debian-9/"    ><span class="crp_title">How to Install and Use Docker on Debian 9</span></a></li><li><a href="https://linux4one.com/how-to-install-and-use-docker-on-ubuntu-18-04/"    ><span class="crp_title">How to Install and Use Docker on Ubuntu 18.04</span></a></li><li><a href="https://linux4one.com/how-to-add-user-to-group-in-linux/"    ><span class="crp_title">How to Add User to Group in Linux</span></a></li><li><a href="https://linux4one.com/how-to-mount-and-unmount-filesystems-in-linux-with-examples/"    ><span class="crp_title">How to Mount and Unmount Filesystems in Linux with Examples</span></a></li><li><a href="https://linux4one.com/how-to-install-and-use-docker-on-centos-7/"    ><span class="crp_title">How to Install and Use Docker on CentOS 7</span></a></li><li><a href="https://linux4one.com/11-wget-command-examples-in-linux-linux-file-downloader/"    ><span class="crp_title">11 Wget Command Examples in Linux (Linux File Downloader)</span></a></li><li><a href="https://linux4one.com/how-to-safely-remove-files-and-directories-using-linux-command-line/"    ><span class="crp_title">How to Safely Remove Files and Directories Using&hellip;</span></a></li><li><a href="https://linux4one.com/how-to-start-stop-and-restart-apache-server/"    ><span class="crp_title">How to Start, Stop and Restart Apache Server</span></a></li></ul><div class="crp_clear"></div></div></aside>  <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-custom_ad_2 td_uid_4_5e16e16c93a0a_rand td_block_template_1 "><style>.td_uid_4_5e16e16c93a0a_rand.td-a-rec-img{text-align:left}.td_uid_4_5e16e16c93a0a_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="4866482941"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="4866482941"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="4866482941"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="4866482941"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }</script> </div> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-custom_ad_1 td_uid_5_5e16e16c93c36_rand td_block_template_1 "><style>.td_uid_5_5e16e16c93c36_rand.td-a-rec-img{text-align:left}.td_uid_5_5e16e16c93c36_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="9447875728"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="9447875728"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="9447875728"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-5763298617442226" data-ad-slot="9447875728"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }</script> </div></div></div></div></div></div><div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-4 "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span12"><div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://linux4one.com/"><img src="https://linux4one.com/wp-content/uploads/2019/02/icon6.png" alt="Linux4one" title="Linux4one"/></a></div><div class="footer-text-wrap">© 2019 Linux4one.com | All Rights Reserved.<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#483b3d3838273a3c082421263d307c27262d662b2725"><span class="__cf_email__" data-cfemail="fe8d8b8e8e918c8abe9297908b86ca91909bd09d9193">[email&#160;protected]</span></a></div></div><div class="footer-social-wrap td-social-style-2"> <span class="td-social-icon-wrap"> <a target="_blank" rel="nofollow" href="https://www.facebook.com/linux4one/?modal=admin_todo_tour" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" rel="nofollow" href="https://twitter.com/Linux4oneC" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-pages-container"><ul id="menu-pages" class="td-subfooter-menu"><li id="menu-item-211" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-211"><a href="https://linux4one.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-212" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-212"><a href="https://linux4one.com/contact-us/">Contact Us</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"></div></div></div></div></div> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>// List of Themes, Classes and Regular expressions
		var template_name = 'Newspaper';
		switch(template_name) {
			case 'twentyeleven' :
					var classes = ['entry-meta'];
					var regex = ' by <a(.*?)\/a>;<span class="sep"> by <\/span>';
					break;
			case 'twentyten' :
					var classes = ['entry-meta'];
					var regex = ' by <a(.*?)\/a>;<span class="meta-sep">by<\/span>';
					break;
			case 'object' :
					var classes = ['post-details', 'post'];
					var regex = ' by <span(.*?)\/span>;<p class="post-details">by';
					break;
			case 'theme-revenge' :
					var classes = ['post-entry-meta'];
					var regex = 'By <a(.*?)\/a> on';
					break;
			case 'Magnificent' :
					var classes = ['meta-info'];
					var regex = '<span>by<\/span> <a(.*?)\/a>;Posted by <a(.*?)\/a> on ';
					break;
			case 'wp-clearphoto' :
					var classes = ['meta'];
					var regex = '\\|\\s*<\/span>\\s*<span class="meta-author">\\s*<a(.*?)\/a>';
					break;
			case 'wp-clearphoto1' :
					var classes = ['meta'];
					var regex = '\\|\\s*<\/span>\\s*<span class="meta-author">\\s*<a(.*?)\/a>';
					break;
			default:
					var classes = ['entry-meta'];
					var regex = ' by <a(.*?)\/a>;<span class="sep"> by <\/span>; <span class="meta-sep">by<\/span>;<span class="meta-sep"> by <\/span>';
		}
				if (typeof classes[0] !== 'undefined' && classes[0] !== null) {
				for(var i = 0; i < classes.length; i++) {
					var elements = document.querySelectorAll('.'+classes[i]);
					for (var j = 0; j < elements.length; j++) {
						var regex_array = regex.split(";");
						for(var k = 0; k < regex_array.length; k++) {
							 if (elements[j].innerHTML.match(new RegExp(regex_array[k], "i"))) {
								 var replaced_txt = elements[j].innerHTML.replace(new RegExp(regex_array[k], "i"), '');
								 elements[j].innerHTML = replaced_txt;
							 }
						}
					}			
				}
			}</script> <script type='text/javascript'>/* <![CDATA[ */ var wpcf7 = {"apiSettings":{"root":"https:\/\/linux4one.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/contact-form-7/includes/js/scripts-ffdbb068761197ae26a16f06bfa579b9.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var copyTheCode = {"selector":"pre","settings":{"selector":"pre","copy-as":"html","button-text":"Copy","button-title":"Copy to Clipboard","button-copy-text":"Copied!","button-position":"inside"},"string":{"title":"Copy to Clipboard","copy":"Copy","copied":"Copied!"}}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/copy-the-code/assets/js/copy-the-code-d2c1a8d5db5e1feb86e97cb299e5cb62.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var tocplus = {"smooth_scroll":"1","smooth_scroll_offset":"120"}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/table-of-contents-plus/front.min.js?ver=1509' defer></script> <script data-minify="1" type='text/javascript' src='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/td-composer/legacy/common/wp_booster/js_dev/tdModalPostImages-4a938198338741daf259004a1b57fe09.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/underscore.min.js?ver=1.8.3' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=96be9388232cf6f1e9ad7a3c9f4e9872' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.7.2' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/comment-reply.min.js?ver=5.3.2' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/wp-review/public/js/js.cookie.min.js?ver=2.1.4' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/wp-util.min.js?ver=5.3.2' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var wpreview = {"ajaxurl":"https:\/\/linux4one.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script data-minify="1" type='text/javascript' src='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/wp-review/public/js/main-21011818798c402cd142e63a86ff1884.js' defer></script> <script data-minify="1" type='text/javascript' src='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/reduce-bounce-rate/js/analyticsjs-87b0342a7878d68f74bc72d1ae9514c4.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=96be9388232cf6f1e9ad7a3c9f4e9872' defer></script> <script data-minify="1" async="async" type='text/javascript' src='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/akismet/_inc/form-c3530ca03c3d516b0dee160324bcd60a.js'></script>  <script>(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://linux4one.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://linux4one.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();</script> <script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	s.src = !("IntersectionObserver" in w) ? "https://linux4one.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-8.15.2.min.js" : "https://linux4one.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-10.17.min.js";
	w.lazyLoadOptions = {
		elements_selector: "img",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		data_sizes: "lazy-sizes",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );
	
	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };
	
	observer.observe(b, config);
}, false);</script> <noscript><link rel='stylesheet' id='wp-block-library-css'  href='https://linux4one.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='contact-form-7-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/contact-form-7/includes/css/styles-438961790fb6a475846385ef6ca3a9c9.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='crp-style-rounded-thumbs-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/contextual-related-posts/css/default-style-a2b72e907f8cb004a1912b9d76ee4671.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='copy-the-code-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/copy-the-code/assets/css/copy-the-code-92d749726da878bd0cfab6125798a1fe.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='saswp-collection-front-css-css'  href='https://linux4one.com/wp-content/plugins/schema-and-structured-data-for-wp/admin_section/css/collection-front.min.css?ver=1.9.17' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='toc-screen-css'  href='https://linux4one.com/wp-content/plugins/table-of-contents-plus/screen.min.css?ver=1509' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='td-plugin-newsletter-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/td-newsletter/style-2eea3d533a39f33f697d7d48c81f422e.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/td-composer/td-multi-purpose/style-6e90ec1cf17f68e61e0b9180c8c38b66.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab%3A400%7CRubik%3A400%7CMontserrat%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.7.2' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='wp_review-style-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/wp-review/public/css/wp-review-db089dc082eb067e3233a2967efc9a1e.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='td-theme-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/themes/Newspaper/style-9afd48c3b779f68531abb291df65a1f8.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main-7096004acac4c7bc6eeb8856f3f610ce.css' type='text/css' media='all' /></noscript><noscript><link data-minify="1" rel='stylesheet' id='tdb_front_style-css'  href='https://linux4one.com/wp-content/cache/min/1/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front-d42b5d47e57d303116b523ab02d9fc3f.css' type='text/css' media='all' /></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1578557804 -->