<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head><style id="rocket-critical-css">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</style><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><meta http-equiv="X-UA-Compatible" content="IE=edge"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://linux4one.com/xmlrpc.php"><title>How to install Pip on Ubuntu 18.04 | Linux4one.com</title> <script>/* You can add more configuration options to webfontloader by previously defining the WebFontConfig with your options */
                            if ( typeof WebFontConfig === "undefined" ) {
                                WebFontConfig = new Object();
                            }
                            WebFontConfig['google'] = {families: ['Roboto:100,300,400,500,700,900,100italic,300italic,400italic,500italic,700italic,900italic', 'IBM+Plex+Serif:100,200,300,400,500,600,700,100italic,200italic,300italic,400italic,500italic,600italic,700italic']};

                            (function() {
                                var wf = document.createElement( 'script' );
                                wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
                                wf.type = 'text/javascript';
                                wf.async = 'true';
                                var s = document.getElementsByTagName( 'script' )[0];
                                s.parentNode.insertBefore( wf, s );
                            })();</script> <meta name="description" content="PIP stands for Python Package Index (PyPI) used for installation and management of software packages in Python. PIP makes it very easier to install packages in python."/><link rel="canonical" href="https://linux4one.com/how-to-install-pip-on-ubuntu-18-04-linux4one/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to install Pip on Ubuntu 18.04 | Linux4one.com" /><meta property="og:description" content="PIP stands for Python Package Index (PyPI) used for installation and management of software packages in Python. PIP makes it very easier to install packages in python." /><meta property="og:url" content="https://linux4one.com/how-to-install-pip-on-ubuntu-18-04-linux4one/" /><meta property="og:site_name" content="Linux4one.com" /><meta property="article:tag" content="pip" /><meta property="article:tag" content="python" /><meta property="article:tag" content="Ubuntu" /><meta property="article:section" content="Ubuntu" /><meta property="article:published_time" content="2018-10-05T04:30:52+00:00" /><meta property="article:modified_time" content="2018-12-13T10:03:44+00:00" /><meta property="og:updated_time" content="2018-12-13T10:03:44+00:00" /><meta property="og:image" content="https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04.jpg" /><meta property="og:image:secure_url" content="https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04.jpg" /><meta property="og:image:width" content="750" /><meta property="og:image:height" content="350" /><meta property="og:image:alt" content="How to install Pip on Ubuntu 18.04" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="PIP stands for Python Package Index (PyPI) used for installation and management of software packages in Python. PIP makes it very easier to install packages in python." /><meta name="twitter:title" content="How to install Pip on Ubuntu 18.04 | Linux4one.com" /><meta name="twitter:image" content="https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04.jpg" /><link rel="alternate" type="application/rss+xml" title="Linux4one.com &raquo; Feed" href="https://linux4one.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Linux4one.com &raquo; Comments Feed" href="https://linux4one.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Linux4one.com &raquo; How to install Pip on Ubuntu 18.04 Comments Feed" href="https://linux4one.com/how-to-install-pip-on-ubuntu-18-04-linux4one/feed/" /><link rel='preload' id='bunyad-shortcodes-css'  href='https://linux4one.com/wp-content/plugins/bunyad-shortcodes/css/shortcodes.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='wp-block-library-css'  href='https://linux4one.com/wp-includes/css/dist/block-library/style.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='contact-form-7-css'  href='https://linux4one.com/wp-content/plugins/contact-form-7/includes/css/styles.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='copy-the-code-css'  href='https://linux4one.com/wp-content/plugins/copy-the-code/assets/css/copy-the-code.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='rs-plugin-settings-css'  href='https://linux4one.com/wp-content/plugins/revslider/public/assets/css/settings.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><style id='rs-plugin-settings-inline-css' type='text/css'></style><link rel='preload' id='zilla-likes-css'  href='https://linux4one.com/wp-content/plugins/tt-plugin/inc/post-likes/styles/zilla-likes.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='font-awesome-css'  href='https://linux4one.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='bootstrap-css'  href='https://linux4one.com/wp-content/themes/trendymag/css/bootstrap.min.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='trendymag-plugins-css'  href='https://linux4one.com/wp-content/themes/trendymag/css/plugins.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='trendymag-print-css'  href='https://linux4one.com/wp-content/themes/trendymag/css/print.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='print' /><link rel='preload' id='stylesheet-css'  href='https://linux4one.com/wp-content/themes/trendymag-child/style.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='trendymag-custom-style-css'  href='https://linux4one.com/wp-content/themes/trendymag/custom-style.php' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='magnificPopup-css'  href='https://linux4one.com/wp-content/plugins/wp-review/public/css/magnific-popup.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='wp_review-style-css'  href='https://linux4one.com/wp-content/plugins/wp-review/public/css/wp-review.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='trendymag-parent-style-css'  href='https://linux4one.com/wp-content/themes/trendymag/style.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='trendymag-child-style-css'  href='https://linux4one.com/wp-content/themes/trendymag-child/style.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='tt-trendyicon-css'  href='https://linux4one.com/wp-content/plugins/tt-plugin/css/trendyicon.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /><link rel='preload' id='tt-style-css'  href='https://linux4one.com/wp-content/plugins/tt-plugin/css/style.css' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' /> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/jquery/jquery-migrate.min.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var zilla_likes = {"ajaxurl":"https:\/\/linux4one.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/tt-plugin/inc/post-likes/scripts/zilla-likes.js' defer></script> <link rel='https://api.w.org/' href='https://linux4one.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linux4one.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linux4one.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.0.1" /><link rel='shortlink' href='https://linux4one.com/?p=63' /><meta name="google-site-verification" content="pLOfliyGyUV2R7ys9u8b93KpTYZnnSTnJ6jjhUMMGFI" /><script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//linux4one.com/?wordfence_lh=1&hid=23A7B4B355699D02B41DB7497923548B');</script><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="preload" type="text/css" href="https://linux4one.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" as="style" onload="this.onload=null;this.rel='stylesheet'" media="screen"><![endif]--><meta name="generator" content="Powered by Slider Revolution 5.4.7.4 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-127584344-1', 'auto');
  ga('send', 'pageview');</script>  <script type="text/javascript">function setREVStartSize(e){									
						try{ e.c=jQuery(e.c);var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;
							if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
						}catch(d){console.log("Failure at Presize of Slider:"+d)}						
					};</script> <style type="text/css" id="wp-custom-css">pre:hover>.copy-the-code-button{display:block;opacity:1;transition:opacity .4s ease}.copy-the-code-button{opacity:0;transition:opacity .4s ease;position:absolute!important;right:0!important;top:0!important;background:#e1e3e8!important;padding:0 10px!important;cursor:pointer!important;box-shadow:none!important;color:#424242!important;font-size:13px!important;font-weight:normal!important;border-radius:4px!important;text-transform:capitalize!important;border:none!important;margin:12px 10px 12px 10px}h1,h2,h3,h4,h5,h6{font-family:'IBM Plex Serif',sans-serif;font-weight:700;color:#202020}body{font-size:18px;line-height:30px;font-weight:400}pre{font-size:16px;line-height:2}h2{font-size:32px;line-height:38px}h3{margin-top:20px;font-size:24px;line-height:38px}p{margin-bottom:1rem;margin-top:1rem;line-height:1.58}.code-label{border:1px solid #ccc;display:block;padding:5px 10px;margin-bottom:-2px;font-weight:400;color:#3a3a3a;background-color:#e5e5e5;border-radius:3px 3px 0 0;text-align:center;font-size:14px;z-index:2;position:relative}.recent-news .entry-title{font-size:17px;line-height:24px;margin-bottom:5px;height:40px}.header-top-wrapper{background-color:#fff;height:36px}.post-wrapper .recent-news{border:1px solid #eeecec;margin-bottom:20px}</style><style type="text/css" title="dynamic-css" class="options-output">body{background-color:#fff;background-repeat:no-repeat;background-size:cover;background-attachment:fixed;background-position:center top}</style><noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script></head><body id="home" class="post-template-default single single-post postid-63 single-format-standard page-builder header-default footer-three has-header-search menu-colored-border has-site-logo has-mobile-logo fullwidth-layout wpb-js-composer js-comp-ver-5.4.4 vc_responsive" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div id="preloader" style="background-color: #ffffff"><div id="status"><div class="status-mes" style="background-image: url(https://linux4one.com/wp-content/themes/trendymag/images/preloader.gif);"></div></div></div><div id="wrapper"><div class="header-wrapper navbar-fixed-top"><div class="header-top-wrapper"><div class="container"><div class="row"><div class="col-md-12"><div class="header-top-contents"><div class="contact-info-wrapper"><div class="header-menu hidden-xs"><div class="menu-pages-container"><ul class="header-nav"><li id="menu-item-211" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-211"><a href="https://linux4one.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-212" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-212"><a href="https://linux4one.com/contact-us/">Contact Us</a></li></ul></div></div></div></div></div></div></div></div><div class="brand-wrapper"><div class="container"><div class="search-box-wrap visible-xs"><div class="search-icon"></div><form role="search" method="get" id="searchform" class="search-form" action="https://linux4one.com/"> <input type="text" class="form-control" value="" name="s" id="s" placeholder="Search"/> <button type="submit"><i class="fa fa-search"></i></button> <input type="hidden" value="post" name="post_type" /></form></div> <button type="button" class="navbar-toggle"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </button><div class="row"><div class="col-sm-3 clearfix"><div class="navbar-brand"><h1> <a href="https://linux4one.com/" title="Linux4one.com"> <img class="site-logo hidden-xs" src="https://linux4one.com/wp-content/uploads/2018/10/55.png" data-at2x="https://linux4one.com/wp-content/uploads/2018/10/110.png" alt="Linux4one.com"/><img class="site-logo visible-xs" src="https://linux4one.com/wp-content/uploads/2018/10/55-1.png" data-at2x="https://linux4one.com/wp-content/uploads/2018/10/110-1.png" alt="Linux4one.com"/> </a></h1></div></div><div class="col-sm-9"><div class="tt-promo text-right"><div class="promo-wrap    "> <img class="img-responsive" src="" alt=""></div></div></div></div></div></div><nav class="navbar navbar-default"><div class="menu-close visible-xs"><i class="fa fa-times"></i></div><div class="main-menu-wrapper clearfix"><div class="container"><div class="search-box-wrap pull-right hidden-sm hidden-xs"><div class="search-icon"></div><form role="search" method="get" id="searchform" class="search-form" action="https://linux4one.com/"> <input type="text" class="form-control" value="" name="s" id="s" placeholder="Search"/> <button type="submit"><i class="fa fa-search"></i></button> <input type="hidden" value="post" name="post_type" /></form></div><div class="main-menu"><ul id="menu-linux" class="menu nav navbar-nav"><li id="menu-item-210" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-210  has-menu-child"><a title="Home" href="https://linux4one.com">Home</a></li><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11  has-menu-child"><a title="Linux" href="https://linux4one.com/category/linux/">Linux</a></li><li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-14  has-menu-child"><a title="Ubuntu" href="https://linux4one.com/category/ubuntu/">Ubuntu</a></li><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12  has-menu-child"><a title="CentOS" href="https://linux4one.com/category/centos/">CentOS</a></li><li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13  has-menu-child"><a title="Debian" href="https://linux4one.com/category/debian/">Debian</a></li><li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15  has-menu-child"><a title="Linux Commands" href="https://linux4one.com/category/linux-commands/">Linux Commands</a></li></ul></div></div></div></nav></div><div id="page-content-wrapper"><section class="page-title single-page-title" role="banner"><div class="container"><div class="tt-breadcrumb"><ul class="breadcrumb"><li> <a href="https://linux4one.com">Home</a></li><li class="active"> <a href="https://linux4one.com/category/ubuntu/">Ubuntu</a> <span class="raquo"> <i class="fa fa-angle-double-right"></i></span> How to install Pip on Ubuntu 18.04</li></ul></div></div></section><div class="news-wrapper content-wrapper single-news single-default"><div class="container"><div class="row"><div class="sidebar-sticky col-md-8 col-sm-12"><div id="main" class="posts-content" role="main"><article id="post-63" class="post-wrapper post-63 post type-post status-publish format-standard has-post-thumbnail hentry category-ubuntu tag-pip tag-python tag-ubuntu" itemscope itemtype="https://schema.org/Article"><header class="featured-wrapper"><div class="entry-meta"><ul class="list-inline"><li><span class="posted-in"> <a class="ubuntu" href="https://linux4one.com/category/ubuntu/" rel="category tag" style="">Ubuntu</a> </span></li><li> <span class="right"><a href="#" class="zilla-likes" id="zilla-likes-63" title="Like this"><span class="zilla-likes-count">0</span> <span class="zilla-likes-postfix"></span></a></span></li><li> <span class="post-comments-number"> <i class="fa fa-comment-o"></i><a href="https://linux4one.com/how-to-install-pip-on-ubuntu-18-04-linux4one/#respond">0</a> </span></li><li><span><i class="fa fa-newspaper-o"></i>3 min read</span></li></ul></div><div class="entry-header"><h2 class="entry-title">How to install Pip on Ubuntu 18.04</h2></div><ul class="entry-meta list-inline clearfix"><li> <span class="author vcard"> <i class="fa fa-user"></i><a class="url fn n" href="https://linux4one.com/author/root_rahul/">root_rahul</a> </span></li><li> <i class="fa fa-calendar"></i><a href="https://linux4one.com/how-to-install-pip-on-ubuntu-18-04-linux4one/" rel="bookmark">05/10/2018</a></li></ul><div class="post-share"><ul class="list-inline"><li> <a class="facebook large-btn" href="//www.facebook.com/sharer.php?u=https%3A%2F%2Flinux4one.com%2Fhow-to-install-pip-on-ubuntu-18-04-linux4one%2F&amp;t=How%20to%20install%20Pip%20on%20Ubuntu%2018.04" title="Share on Facebook!" target="_blank"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a></li><li> <a class="twitter large-btn" href="//twitter.com/home?status=Reading%3A%20https%3A%2F%2Flinux4one.com%2Fhow-to-install-pip-on-ubuntu-18-04-linux4one%2F" title="Share on Twitter!" target="_blank"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a></li><li> <a class="google-plus" href="//plus.google.com/share?url=https%3A%2F%2Flinux4one.com%2Fhow-to-install-pip-on-ubuntu-18-04-linux4one%2F" title="Share on Google+!" target="_blank"><i class="fa fa-google-plus"></i></a></li><li> <a class="linkedin" href="//www.linkedin.com/shareArticle?url=https%3A%2F%2Flinux4one.com%2Fhow-to-install-pip-on-ubuntu-18-04-linux4one%2F&amp;mini=true&amp;title=How%20to%20install%20Pip%20on%20Ubuntu%2018.04" title="Share on Linkedin!" target="_blank"><i class="fa fa-linkedin"></i></a></li><li> <a class="pinterest" href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Flinux4one.com%2Fhow-to-install-pip-on-ubuntu-18-04-linux4one%2F&media=https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04.jpg" title="Share on Pinterest!" rel="nofollow" target="_blank"><i class="fa fa-pinterest"></i></a></li></ul></div><div class="post-thumbnail"> <img width="750" height="350" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04.jpg" class="img-responsive wp-post-image" alt="How to install Pip on Ubuntu 18.04" data-lazy-srcset="https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04.jpg 750w, https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04-300x140.jpg 300w" data-lazy-sizes="(max-width: 750px) 100vw, 750px" /><noscript><img width="750" height="350" src="https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04.jpg" class="img-responsive wp-post-image" alt="How to install Pip on Ubuntu 18.04" srcset="https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04.jpg 750w, https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04-300x140.jpg 300w" sizes="(max-width: 750px) 100vw, 750px" /></noscript></div></header><div class="blog-content"><div class="entry-content"><h2>Install PIP on Ubuntu 18.04</h2><p>PIP stands for <em>Python Package Index (PyPI)</em> used for installation and management of software packages in Python. PIP makes it very easier to install packages in Python. Now you are going to install PIP on Ubuntu 18.04 and you will also learn some basic commands in PIP.</p><h3>Prerequisites</h3><p>Before you start to <em>install PIP on Ubuntu 18.04</em>. You must have non root user account on your server with sudo privileges.</p><h3>Before You Begin</h3><p>By default <a href="https://linux4one.com/how-to-install-python-on-ubuntu-18-04">Python 3</a> is installed in Ubuntu 18.04 but if you have made any changes then you can check version of python by entering following</p><pre>    python --version</pre><pre>    Output:
        Python 3.6
</pre><h3>1. Install PIP for Python 3</h3><p>Before start installing PIP on Ubuntu, you should update package index by entering following.</p><pre>sudo apt update</pre><p>Now to install PIP on Ubuntu enter following command</p><pre>sudo apt install python3-pip</pre><p>To <em>confirm installation and check </em>version of PIP enter following command</p><pre>pip3 --version</pre><p>Output should be :</p><pre>Output:
    pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.6)</pre><p>If output comes as above then you have successfully installed PIP on Ubuntu .</p><p><em>NOTE &#8211; version number of PIP may change with time.</em></p><h3>2. Install PIP For Python 2</h3><p>Update the package manager index by entering following command</p><pre>sudo apt update</pre><p>After updating package manager index to install PIP for Python 2 enter following in terminal</p><pre>sudo apt install python-pip</pre><p>Check version and confirm installation by entering following</p><pre>pip --version</pre><p>Output should be :</p><pre>Output
    pip 9.0.1 from /usr/lib/python2.7/dist-packages (python 2.7)</pre><h3>3. Basic usage of PIP for python 3</h3><p>To list all the commands in PIP enter following</p><pre>pip3 --help</pre><p>Get information of specific command enter following</p><pre>pip3 install --help</pre><p>To search package with PIP enter following</p><pre>pip3 search PACKAGE_NAME</pre><p>Install package with PIP enter following in terminal</p><pre>pip3 install PACKAGE_NAME</pre><p>To install package from requirements file</p><pre>pip3 install -r requirements.txt</pre><p>Upgrade package with PIP</p><pre>pip3 install --upgrade PACKAGE_NAME</pre><p>Uninstall package with PIP</p><pre>pip3 uninstall PACKAGE_NAME</pre><h3>4. Basic usage of PIP for python 2</h3><p>To list all the commands in PIP enter following</p><pre>pip --help</pre><p>Get information of specific command enter following</p><pre>pip install --help</pre><p>To search package with PIP enter following</p><pre>pip search PACKAGE_NAME</pre><p>Install package with PIP enter following in terminal</p><pre>pip install PACKAGE_NAME</pre><p>To install package from requirements file</p><pre>pip install -r requirements.txt</pre><p>Upgrade package with PIP</p><pre>pip install --upgrade PACKAGE_NAME</pre><p>Uninstall package with PIP</p><pre>pip uninstall PACKAGE_NAME</pre><h3>Conclusion</h3><p>Here you have learnt how to install PIP on Ubuntu 18.04 for python 3 and python 2. If you have any queries regarding this please don&#8217;t forget to comment below.</p><h3>Related Tutorials</h3><ul><li><a href="https://linux4one.com/how-to-install-python-on-ubuntu-18-04">How to install Python on Ubuntu</a></li></ul></div></div><div class="post-share"><ul class="list-inline"><li> <a class="facebook large-btn" href="//www.facebook.com/sharer.php?u=https%3A%2F%2Flinux4one.com%2Fhow-to-install-pip-on-ubuntu-18-04-linux4one%2F&amp;t=How%20to%20install%20Pip%20on%20Ubuntu%2018.04" title="Share on Facebook!" target="_blank"><i class="fa fa-facebook-official"></i><span>Share on Facebook</span></a></li><li> <a class="twitter large-btn" href="//twitter.com/home?status=Reading%3A%20https%3A%2F%2Flinux4one.com%2Fhow-to-install-pip-on-ubuntu-18-04-linux4one%2F" title="Share on Twitter!" target="_blank"><i class="fa fa-twitter"></i><span>Share on Twitter</span></a></li><li> <a class="google-plus" href="//plus.google.com/share?url=https%3A%2F%2Flinux4one.com%2Fhow-to-install-pip-on-ubuntu-18-04-linux4one%2F" title="Share on Google+!" target="_blank"><i class="fa fa-google-plus"></i></a></li><li> <a class="linkedin" href="//www.linkedin.com/shareArticle?url=https%3A%2F%2Flinux4one.com%2Fhow-to-install-pip-on-ubuntu-18-04-linux4one%2F&amp;mini=true&amp;title=How%20to%20install%20Pip%20on%20Ubuntu%2018.04" title="Share on Linkedin!" target="_blank"><i class="fa fa-linkedin"></i></a></li><li> <a class="pinterest" href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Flinux4one.com%2Fhow-to-install-pip-on-ubuntu-18-04-linux4one%2F&media=https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04.jpg" title="Share on Pinterest!" rel="nofollow" target="_blank"><i class="fa fa-pinterest"></i></a></li></ul></div><footer class="entry-footer clearfix"><div class="post-tags"> <span class="tags-links"> <i class="fa fa-tag"></i><a href="https://linux4one.com/tag/pip/" rel="tag">pip</a>, <a href="https://linux4one.com/tag/python/" rel="tag">python</a>, <a href="https://linux4one.com/tag/ubuntu/" rel="tag">Ubuntu</a> </span></div><span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="root_rahul"></span><meta itemprop="datePublished" content="2018-10-05T10:00:52+00:00"><meta itemprop="dateModified" content="2018-12-13T15:33:44+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://linux4one.com/how-to-install-pip-on-ubuntu-18-04-linux4one/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://linux4one.com/wp-content/uploads/2018/10/55.png"></span><meta itemprop="name" content="Linux4one.com"></span><meta itemprop="headline " content="How to install Pip on Ubuntu 18.04"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://linux4one.com/wp-content/uploads/2018/10/How-to-install-Pip-on-Ubuntu-18.04.jpg"><meta itemprop="width" content="750"><meta itemprop="height" content="350"></span></footer></article><div class="subscribe-form single-news-newsletter"> <i class="fa fa-envelope"></i><h2>Newsletter Subscription</h2><h3>Subscribe to our mailing list to get the new updates!</h3><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-256" method="post" data-id="256" data-name="" ><div class="mc4wp-form-fields"><h3 class="widget-title">Newsletter</h3><div class="mc4wp-form-fields"><div class="form-group"> <input type="email" class="form-control" name="EMAIL" placeholder="Enter your email here" required="required"></div><input type="submit" class="btn btn-primary" value="Subscribe"><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"></div><input type="hidden" name="_mc4wp_timestamp" value="1542868107"><input type="hidden" name="_mc4wp_form_id" value="203"><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1"></div><div class="mc4wp-response"></div></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1544718085" /><input type="hidden" name="_mc4wp_form_id" value="256" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></div><nav class="single-post-navigation" role="navigation"><div class="row"><div class="col-sm-6 col-xs-12"><div class="previous-post-link"> <span class="previous"><a href="https://linux4one.com/how-to-install-lemp-stack-on-ubuntu-18-04/" rel="prev"><i class="fa fa-angle-double-left" aria-hidden="true"></i>Previous Post</a></span><h3 class="entry-title"> <a href="https://linux4one.com/how-to-install-lemp-stack-on-ubuntu-18-04/">How to install LEMP Stack on Ubuntu 18.04</a></h3></div></div><div class="col-sm-6 col-xs-12 pull-right"><div class="next-post-link"> <span class="next"><a href="https://linux4one.com/how-to-install-python-on-ubuntu-18-04/" rel="next">Next Post<i class="fa fa-angle-double-right" aria-hidden="true"></i></a></span><h3 class="entry-title"> <a href="https://linux4one.com/how-to-install-python-on-ubuntu-18-04/">How to install Python on Ubuntu 18.04</a></h3></div></div></div></nav><div class="post-wrapper related-post style-one"><div class="row"><div class="col-md-12"><div class="section-intro"><h2>Related Article</h2></div></div><div class="col-md-6 col-sm-6"><div class="recent-news post-454 post type-post status-publish format-standard has-post-thumbnail hentry category-ubuntu tag-nodejs tag-npm tag-ubuntu"><div class="entry-meta"> <span class="posted-in"> <a class="ubuntu" href="https://linux4one.com/category/ubuntu/" rel="category tag" style="">Ubuntu</a> </span></div> <a href="https://linux4one.com/how-to-install-node-js-with-npm-on-ubuntu-18-04/"><div class="entry-thumb" itemprop="image"> <img width="645" height="350" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://linux4one.com/wp-content/uploads/2018/11/How-to-install-Node.js-with-npm-on-Ubuntu-18.04-1-645x350.jpg" class="img-responsive wp-post-image" alt="How to install Node.js with npm on Ubuntu 18.04" /><noscript><img width="645" height="350" src="https://linux4one.com/wp-content/uploads/2018/11/How-to-install-Node.js-with-npm-on-Ubuntu-18.04-1-645x350.jpg" class="img-responsive wp-post-image" alt="How to install Node.js with npm on Ubuntu 18.04" /></noscript></div> </a><div class="post-contents"><h2 class="entry-title" itemprop="headline"><a href="https://linux4one.com/how-to-install-node-js-with-npm-on-ubuntu-18-04/" rel="bookmark" itemprop="url">How to install Node.js with npm on Ubuntu 18.04</a></h2><div class="entry-meta"><ul class="list-inline"><li><span class="entry-time published" itemprop="datePublished" content="26/11/2018"><a href="https://linux4one.com/how-to-install-node-js-with-npm-on-ubuntu-18-04/"><i class="fa fa-clock-o"></i>26/11/2018</a></span></li><li> <span class="post-comments-number"> <i class="fa fa-comment-o"></i><span>Closed</span> </span></li></ul></div></div></div></div><div class="col-md-6 col-sm-6"><div class="recent-news post-540 post type-post status-publish format-standard has-post-thumbnail hentry category-ubuntu tag-lets-encrypt tag-nginx tag-ubuntu"><div class="entry-meta"> <span class="posted-in"> <a class="ubuntu" href="https://linux4one.com/category/ubuntu/" rel="category tag" style="">Ubuntu</a> </span></div> <a href="https://linux4one.com/secure-nginx-with-lets-encrypt-ssl-on-ubuntu-18-04/"><div class="entry-thumb" itemprop="image"> <img width="645" height="350" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://linux4one.com/wp-content/uploads/2018/11/How-To-Secure-Nginx-with-Lets-Encrypt-SSL-on-Ubuntu-18.04-645x350.jpg" class="img-responsive wp-post-image" alt="How To Secure Nginx with Let&#039;s Encrypt SSL on Ubuntu 18.04" /><noscript><img width="645" height="350" src="https://linux4one.com/wp-content/uploads/2018/11/How-To-Secure-Nginx-with-Lets-Encrypt-SSL-on-Ubuntu-18.04-645x350.jpg" class="img-responsive wp-post-image" alt="How To Secure Nginx with Let&#039;s Encrypt SSL on Ubuntu 18.04" /></noscript></div> </a><div class="post-contents"><h2 class="entry-title" itemprop="headline"><a href="https://linux4one.com/secure-nginx-with-lets-encrypt-ssl-on-ubuntu-18-04/" rel="bookmark" itemprop="url">Secure Nginx with Let&#8217;s Encrypt SSL on Ubuntu 18.04</a></h2><div class="entry-meta"><ul class="list-inline"><li><span class="entry-time published" itemprop="datePublished" content="25/11/2018"><a href="https://linux4one.com/secure-nginx-with-lets-encrypt-ssl-on-ubuntu-18-04/"><i class="fa fa-clock-o"></i>25/11/2018</a></span></li><li> <span class="post-comments-number"> <i class="fa fa-comment-o"></i><span>Closed</span> </span></li></ul></div></div></div></div><div class="col-md-6 col-sm-6"><div class="recent-news post-434 post type-post status-publish format-standard has-post-thumbnail hentry category-ubuntu tag-ubuntu"><div class="entry-meta"> <span class="posted-in"> <a class="ubuntu" href="https://linux4one.com/category/ubuntu/" rel="category tag" style="">Ubuntu</a> </span></div> <a href="https://linux4one.com/how-to-check-ubuntu-version/"><div class="entry-thumb" itemprop="image"> <img width="645" height="350" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://linux4one.com/wp-content/uploads/2018/11/How-to-check-Ubuntu-version-1-645x350.jpg" class="img-responsive wp-post-image" alt="How to check Ubuntu version" /><noscript><img width="645" height="350" src="https://linux4one.com/wp-content/uploads/2018/11/How-to-check-Ubuntu-version-1-645x350.jpg" class="img-responsive wp-post-image" alt="How to check Ubuntu version" /></noscript></div> </a><div class="post-contents"><h2 class="entry-title" itemprop="headline"><a href="https://linux4one.com/how-to-check-ubuntu-version/" rel="bookmark" itemprop="url">How To Check Ubuntu Version</a></h2><div class="entry-meta"><ul class="list-inline"><li><span class="entry-time published" itemprop="datePublished" content="22/11/2018"><a href="https://linux4one.com/how-to-check-ubuntu-version/"><i class="fa fa-clock-o"></i>22/11/2018</a></span></li><li> <span class="post-comments-number"> <i class="fa fa-comment-o"></i><span>Closed</span> </span></li></ul></div></div></div></div><div class="col-md-6 col-sm-6"><div class="recent-news post-349 post type-post status-publish format-standard has-post-thumbnail hentry category-ubuntu tag-composer tag-ubuntu"><div class="entry-meta"> <span class="posted-in"> <a class="ubuntu" href="https://linux4one.com/category/ubuntu/" rel="category tag" style="">Ubuntu</a> </span></div> <a href="https://linux4one.com/how-to-install-composer-on-ubuntu-18-04/"><div class="entry-thumb" itemprop="image"> <img width="645" height="350" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://linux4one.com/wp-content/uploads/2018/11/How-to-install-Composer-on-Ubuntu-18.04-1-645x350.jpg" class="img-responsive wp-post-image" alt="How to install Composer on Ubuntu 18.04" /><noscript><img width="645" height="350" src="https://linux4one.com/wp-content/uploads/2018/11/How-to-install-Composer-on-Ubuntu-18.04-1-645x350.jpg" class="img-responsive wp-post-image" alt="How to install Composer on Ubuntu 18.04" /></noscript></div> </a><div class="post-contents"><h2 class="entry-title" itemprop="headline"><a href="https://linux4one.com/how-to-install-composer-on-ubuntu-18-04/" rel="bookmark" itemprop="url">How to install Composer on Ubuntu 18.04</a></h2><div class="entry-meta"><ul class="list-inline"><li><span class="entry-time published" itemprop="datePublished" content="12/11/2018"><a href="https://linux4one.com/how-to-install-composer-on-ubuntu-18-04/"><i class="fa fa-clock-o"></i>12/11/2018</a></span></li><li> <span class="post-comments-number"> <i class="fa fa-comment-o"></i><span>Closed</span> </span></li></ul></div></div></div></div></div></div><div id="comments" class="comments-wrapper"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"> Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-install-pip-on-ubuntu-18-04-linux4one/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://linux4one.com/wp-comments-post.php" method="post"
id="commentform"
class="form-horizontal comment-form" novalidate                          role="form"><div class="alert alert-info comment-notes">Your email address will not be published. Required fields are marked <span class="required">*</span></div><div class="form-group"><div class="col-sm-6 comment-form-author"> <input   class="form-control"  id="author"
placeholder="Name" name="author" type="text"
value=""  aria-required='true' /></div><div class="col-sm-6 comment-form-email"> <input id="email" class="form-control" name="email"
placeholder="Email" type="email"
value=""  aria-required='true' /></div></div><div class="form-group"><div class=" col-sm-12 comment-form-url"><input  class="form-control" placeholder="Website"  id="url" name="url" type="url" value=""  /></div></div><div class="form-group comment-form-comment"><div class="col-sm-12"><textarea class="form-control" id="comment" name="comment" placeholder="Comment" rows="8" aria-required="true"></textarea></div></div><div class="form-allowed-tags">You may use these <abbr title="HyperText Markup Language">HTML</abbr> tags and attributes: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></div><div class="form-submit"> <input class="btn btn-primary" name="submit" type="submit"
id="submit"
value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='63' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></div><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="fee113697b" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="33"/></p></form></div></div></div></div><div class="sidebar-sticky col-md-4 col-sm-12"><div class="tt-sidebar-wrapper right-sidebar" role="complementary"><div id="categories-6" class="widget widget_categories"><h3 class="widget-title">Categories</h3><ul><li class="cat-item cat-item-5"><a href="https://linux4one.com/category/centos/" >CentOS</a></li><li class="cat-item cat-item-6"><a href="https://linux4one.com/category/debian/" >Debian</a></li><li class="cat-item cat-item-3"><a href="https://linux4one.com/category/linux/" >Linux</a></li><li class="cat-item cat-item-4"><a href="https://linux4one.com/category/ubuntu/" >Ubuntu</a></li></ul></div><div id="recent-posts-2" class="widget widget_recent_entries"><h3 class="widget-title">Recent Posts</h3><ul><li> <a href="https://linux4one.com/how-to-install-mariadb-10-on-debian-9/">How to install MariaDB 10 on Debian 9</a></li><li> <a href="https://linux4one.com/how-to-install-git-on-debian-9/">How to install Git on Debian 9</a></li><li> <a href="https://linux4one.com/how-to-secure-nginx-with-lets-encrypt-ssl-on-debian-9/">How To Secure Nginx with Let&#8217;s Encrypt SSL on Debian 9</a></li><li> <a href="https://linux4one.com/secure-nginx-with-lets-encrypt-ssl-on-centos-7/">Secure Nginx with Let&#8217;s Encrypt SSL on CentOS 7</a></li><li> <a href="https://linux4one.com/how-to-install-node-js-with-npm-on-centos-7/">How to install Node.js with npm on CentOS 7</a></li><li> <a href="https://linux4one.com/how-to-install-node-js-with-npm-on-debian-9/">How to install Node.js with npm on Debian 9</a></li><li> <a href="https://linux4one.com/how-to-install-node-js-with-npm-on-ubuntu-18-04/">How to install Node.js with npm on Ubuntu 18.04</a></li><li> <a href="https://linux4one.com/secure-nginx-with-lets-encrypt-ssl-on-ubuntu-18-04/">Secure Nginx with Let&#8217;s Encrypt SSL on Ubuntu 18.04</a></li><li> <a href="https://linux4one.com/how-to-list-users-in-linux/">How to List Users in Linux</a></li><li> <a href="https://linux4one.com/how-to-check-ubuntu-version/">How To Check Ubuntu Version</a></li></ul></div></div></div></div></div></div><footer class="footer-section footer-three-wrapper text-center"><div class="container"><div class="row"><div class="col-xs-12"><div class="footer-logo"> <a href="https://linux4one.com/" title="Linux4one.com"> <img src="https://linux4one.com/wp-content/uploads/2018/10/55-2.png" data-at2x="https://linux4one.com/wp-content/themes/trendymag/images/footer-logo2x.png" alt="Linux4one.com"/> </a></div><div class="footer-about-text"> <address><span class="address-info">Email: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="582b2d2828372a2c183431362d206c37363d763b3735">[email&#160;protected]</a></span></address></div><div class="social-links-wrap"><div class="social-icon"><ul class="list-inline"><li><a href="#"><i class="fa fa-facebook"></i></a></li><li><a href="#"><i class="fa fa-twitter"></i></a></li><li><a href="#"><i class="fa fa-google-plus"></i></a></li><li><a href="#"><i class="fa fa-pinterest"></i></a></li></ul></div></div><div class="copyright"> Copyright © 2018 | All Rights Reserved | Linux4one.com</div></div></div></div></footer></div></div>  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript'>/* <![CDATA[ */ var wpcf7 = {"apiSettings":{"root":"https:\/\/linux4one.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/contact-form-7/includes/js/scripts.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var copyTheCode = {"selector":"pre","settings":{"selector":"pre"},"string":{"title":"Copy the Code","copy":"Copy","copied":"Copied!"}}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/copy-the-code/assets/js/copy-the-code.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/silicon-counters/framework/assets/js/silicon-counters.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/themes/trendymag/js/bootstrap.min.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/themes/trendymag/js/plugins.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/themes/trendymag/js/weather.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/imagesloaded.min.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/masonry.min.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/jquery/jquery.masonry.min.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var trendymagJSObject = {"trendymag_sticky_menu":"1","ajaxurl":"https:\/\/linux4one.com\/wp-admin\/admin-ajax.php","trendymag_breaking_news":"1","trendymag_share":"1","trendymag_share_button":{"facebook":"1","twitter":"1","tumblr":"","stumbleupon":"","digg":"1","reddit":"","linkedin":""},"trendymag_facebook_app_id":null,"trendymag_twitter_username":null,"trendymag_rtl":null}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/themes/trendymag/js/scripts.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/comment-reply.min.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/wp-review/public/js/js.cookie.min.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/wp-review/public/js/jquery.magnific-popup.min.js' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/underscore.min.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/wp-util.min.js' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var wpreview = {"ajaxurl":"https:\/\/linux4one.com\/wp-admin\/admin-ajax.php","rateAllFeatures":"Please rate all features","verifiedPurchase":"(Verified purchase)"}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/wp-review/public/js/main.js' defer></script> <script async="async" type='text/javascript' src='https://linux4one.com/wp-content/plugins/akismet/_inc/form.js'></script> <script type='text/javascript'>/* <![CDATA[ */ var mc4wp_forms_config = []; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js' defer></script> <!--[if lte IE 9]> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js'></script> <![endif]--> <script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	s.src = !("IntersectionObserver" in w) ? "https://linux4one.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-8.15.2.min.js" : "https://linux4one.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-10.17.min.js";
	w.lazyLoadOptions = {
		elements_selector: "img",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		data_sizes: "lazy-sizes",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );
	
	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };
	
	observer.observe(b, config);
}, false);</script> <noscript><link rel='stylesheet' id='bunyad-shortcodes-css'  href='https://linux4one.com/wp-content/plugins/bunyad-shortcodes/css/shortcodes.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='wp-block-library-css'  href='https://linux4one.com/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='contact-form-7-css'  href='https://linux4one.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='copy-the-code-css'  href='https://linux4one.com/wp-content/plugins/copy-the-code/assets/css/copy-the-code.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='rs-plugin-settings-css'  href='https://linux4one.com/wp-content/plugins/revslider/public/assets/css/settings.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='zilla-likes-css'  href='https://linux4one.com/wp-content/plugins/tt-plugin/inc/post-likes/styles/zilla-likes.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='font-awesome-css'  href='https://linux4one.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='bootstrap-css'  href='https://linux4one.com/wp-content/themes/trendymag/css/bootstrap.min.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='trendymag-plugins-css'  href='https://linux4one.com/wp-content/themes/trendymag/css/plugins.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='trendymag-print-css'  href='https://linux4one.com/wp-content/themes/trendymag/css/print.css' type='text/css' media='print' /></noscript><noscript><link rel='stylesheet' id='stylesheet-css'  href='https://linux4one.com/wp-content/themes/trendymag-child/style.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='trendymag-custom-style-css'  href='https://linux4one.com/wp-content/themes/trendymag/custom-style.php' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='magnificPopup-css'  href='https://linux4one.com/wp-content/plugins/wp-review/public/css/magnific-popup.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='wp_review-style-css'  href='https://linux4one.com/wp-content/plugins/wp-review/public/css/wp-review.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='trendymag-parent-style-css'  href='https://linux4one.com/wp-content/themes/trendymag/style.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='trendymag-child-style-css'  href='https://linux4one.com/wp-content/themes/trendymag-child/style.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='tt-trendyicon-css'  href='https://linux4one.com/wp-content/plugins/tt-plugin/css/trendyicon.css' type='text/css' media='all' /></noscript><noscript><link rel='stylesheet' id='tt-style-css'  href='https://linux4one.com/wp-content/plugins/tt-plugin/css/style.css' type='text/css' media='all' /></noscript><noscript><link rel="stylesheet" type="text/css" href="https://linux4one.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1544718085 -->