<!doctype html > <!--[if IE 8]><html class="ie8" lang="en"> <![endif]--> <!--[if IE 9]><html class="ie9" lang="en"> <![endif]--> <!--[if gt IE 8]><!--><html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]--><head><title>How to Use grep Command in Linux with Examples | Linux4one</title><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://linux4one.com/xmlrpc.php" /><meta property="og:image" content="https://linux4one.com/wp-content/uploads/2019/01/How-to-Use-grep-Command-in-Linux-with-Examples-1.jpg" /><link rel="icon" type="image/png" href="https://linux4one.com/wp-content/uploads/2018/12/rb.png"><link rel="canonical" href="https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="How to Use grep Command in Linux with Examples | Linux4one" /><meta property="og:description" content="Contents1 Basic Syntax for grep Command2 Grep command to find a particular string inside the file3 Display Number Of Matching Lines4 Invert Match in Grep Command5 Recursive Search6 Search String in Standard Output7 Search Exact Matching Words8 Show Number of Lines Matching9 Conclusion Use grep Command in Linux The grep command used to find a &hellip;" /><meta property="og:url" content="https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/" /><meta property="og:site_name" content="Linux4one" /><meta property="article:tag" content="grep" /><meta property="article:tag" content="grep command" /><meta property="article:tag" content="linux commands" /><meta property="article:tag" content="terminal" /><meta property="article:section" content="Linux Commands" /><meta property="article:published_time" content="2019-01-19T16:30:23+00:00" /><meta property="article:modified_time" content="2019-01-20T15:08:07+00:00" /><meta property="og:updated_time" content="2019-01-20T15:08:07+00:00" /><meta property="og:image" content="https://linux4one.com/wp-content/uploads/2019/01/How-to-Use-grep-Command-in-Linux-with-Examples-1.jpg" /><meta property="og:image:secure_url" content="https://linux4one.com/wp-content/uploads/2019/01/How-to-Use-grep-Command-in-Linux-with-Examples-1.jpg" /><meta property="og:image:width" content="750" /><meta property="og:image:height" content="350" /><meta property="og:image:alt" content="How to Use grep Command in Linux with Examples" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Contents1 Basic Syntax for grep Command2 Grep command to find a particular string inside the file3 Display Number Of Matching Lines4 Invert Match in Grep Command5 Recursive Search6 Search String in Standard Output7 Search Exact Matching Words8 Show Number of Lines Matching9 Conclusion Use grep Command in Linux The grep command used to find a [&hellip;]" /><meta name="twitter:title" content="How to Use grep Command in Linux with Examples | Linux4one" /><meta name="twitter:image" content="https://linux4one.com/wp-content/uploads/2019/01/How-to-Use-grep-Command-in-Linux-with-Examples-1.jpg" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Linux4one &raquo; Feed" href="https://linux4one.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Linux4one &raquo; Comments Feed" href="https://linux4one.com/comments/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><link rel='stylesheet' id='wp-block-library-css'  href='https://linux4one.com/wp-includes/css/dist/block-library/style.min.css?ver=5.0.3' type='text/css' media='all' /><link rel='stylesheet' id='contact-form-7-css'  href='https://linux4one.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.1' type='text/css' media='all' /><link rel='stylesheet' id='copy-the-code-css'  href='https://linux4one.com/wp-content/plugins/copy-the-code/assets/css/copy-the-code.css?ver=1.3.1' type='text/css' media='all' /><link rel='stylesheet' id='toc-screen-css'  href='https://linux4one.com/wp-content/plugins/table-of-contents-plus/screen.min.css?ver=1509' type='text/css' media='all' /><link rel='stylesheet' id='td-plugin-newsletter-css'  href='https://linux4one.com/wp-content/plugins/td-newsletter/style.css?ver=9.2' type='text/css' media='all' /><link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://linux4one.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=c05702a41ebbb3f5c0473f6df376a5d3' type='text/css' media='all' /><link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Montserrat%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;ver=9.2' type='text/css' media='all' /><link rel='stylesheet' id='magnificPopup-css'  href='https://linux4one.com/wp-content/plugins/wp-review/public/css/magnific-popup.css?ver=1.1.0' type='text/css' media='all' /><link rel='stylesheet' id='wp_review-style-css'  href='https://linux4one.com/wp-content/plugins/wp-review/public/css/wp-review.css?ver=5.1.7' type='text/css' media='all' /><link rel='stylesheet' id='td-theme-css'  href='https://linux4one.com/wp-content/themes/Newspaper/style.css?ver=9.2' type='text/css' media='all' /><link rel='stylesheet' id='tdb_front_style-css'  href='https://linux4one.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=9b2b18e69ad07d597ad9079b6a4ae65e' type='text/css' media='all' /> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1' defer></script> <link rel='https://api.w.org/' href='https://linux4one.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linux4one.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linux4one.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.0.3" /><link rel='shortlink' href='https://linux4one.com/?p=1283' /><meta name="google-site-verification" content="pLOfliyGyUV2R7ys9u8b93KpTYZnnSTnJ6jjhUMMGFI" /><meta name="msvalidate.01" content="4B4F6E58CA4F6A24E0B4D3BA596F87DE" /> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-1279672473328090",
    enable_page_level_ads: true
  });</script><style type="text/css">div#toc_container{width:100%}</style><script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//linux4one.com/?wordfence_lh=1&hid=C9B0C603B25E7DC93229E1E0E695FA43');</script> <script>window.tdwGlobal = {"adminUrl":"https:\/\/linux4one.com\/wp-admin\/","wpRestNonce":"05b05836f7","wpRestUrl":"https:\/\/linux4one.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};</script> <!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--><meta name="onesignal" content="wordpress-plugin"/><link rel="manifest"
href="https://linux4one.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/> <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://linux4one.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '9ca03889-aa62-4288-bc49-9ba69e68905b';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Linux4one";
oneSignal_options['welcomeNotification']['message'] = "Thank you for subscribing";
oneSignal_options['path'] = "https://linux4one.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
              oneSignal_options['autoRegister'] = false;
              OneSignal.showHttpPrompt();
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <link rel="amphtml" href="https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/amp/">  <script>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</script> <style>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</style> <script type="application/ld+json">{
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://linux4one.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://linux4one.com/category/linux-commands/",
                    "name": "Linux Commands"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/",
                    "name": "How to Use grep Command in Linux with Examples"                                
                }
            }    
        ]
    }</script>  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-127584344-1', 'auto');
  ga('send', 'pageview');</script> <style type="text/css" id="wp-custom-css">.td-module-title{font-family:merriweather-regular-webfont!important;font-weight:600}.td-boxed-layout .vc_row{background-color:#fff!important}pre{font-size:17px;font-weight:400;padding:14px 14px 14px 14px;background:#f3f3f3!important}pre:hover>.copy-the-code-button{opacity:1}.copy-the-code-button:hover{background:#d5d5d5!important}.copy-the-code-button{opacity:0;position:absolute!important;right:10px!important;top:10px!important;background:#e0e0e0!important;padding:3px 10px!important;cursor:pointer!important;box-shadow:none!important;color:#424242!important;font-size:13px!important;font-weight:normal!important;border-radius:4px!important;text-transform:capitalize!important;border:none!important}#toc_container{background:#f4f7fc;border:none}#toc_container p.toc_title{text-align:left;font-size:23px}#toc_container a{text-decoration:none;text-shadow:none;font-size:18px;color:#333;line-height:30px}.td-post-small-box a{color:#fff;border-radius:5px;border:none;background:#dc2427;font-size:17px;display:block;float:left;margin-left:4px;line-height:18px;padding:7px 9px;height:35px}.td-post-small-box span{color:#fff;border-radius:5px;border:none;background:#333;font-size:17px;display:block;float:left;margin-left:4px;line-height:18px;padding:7px 9px;height:35px}.td_module_6 .entry-title{font-size:15px;line-height:18px;font-weight:700}.td-module-thumb img{min-height:100%}.td-load-more-wrap a{font-weight:500;font-size:20px;color:#fff;background:#58b7e3;border:none;border-radius:5px;padding:10px 25px}.td-load-more-wrap a:hover{background:#208abc}.td-post-date time{font-size:13px}.item-details{position:relative;top:50%}.td-category-pulldown-filter{display:none}.td-category{height:40px!important}.entry-category a{border-radius:5px;padding:12px 10px!important;font-size:15px!important;font-weight:600}.pre_venv::before{content:"(venv) $ ";color:#838383}.pre_output::before{display:block;content:"Output";color:#838383;margin-bottom:.7rem}.related_distros{background-color:#060}.related_distros>p{padding:10px;color:#fff;font-weight:700}.related_distros>ul{padding:0;list-style:none}.related_distros>ul>li{display:inline-block;zoom:1;display:inline}.related_distros>ul>li>a{color:#fff;width:50%}</style><style>.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.sfHover>a,.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>li>a:hover,.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,.tds-button2 .tdm-btn-text,.tds-button2 i,.tds-button5:hover .tdm-btn-text,.tds-button5:hover i,.tds-button6 .tdm-btn-text,.tds-button6 i,.tdm_block_list .tdm-list-item i,.tdm_block_pricing .tdm-pricing-feature i,.tdm-social-item i{color:#dc2427}.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-menu-item>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>li>a:hover,.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu>.sfHover>a,.tds-button1,.tds-button6:after,.tds-title2 .tdm-title-line:after,.tds-title3 .tdm-title-line:after,.tdm_block_pricing.tdm-pricing-featured:before,.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,.tds-progress-bar1 .tdm-progress-bar:after,.tds-progress-bar2 .tdm-progress-bar:after,.tds-social3 .tdm-social-item{background-color:#dc2427}.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-item>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-menu-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>.current-category-ancestor>a,.tdm-menu-active-style4 .tdm-header .sf-menu>li>a:hover,.tdm-menu-active-style4 .tdm-header .sf-menu>.sfHover>a,.tds-button2:before,.tds-button6:before,.tds-progress-bar3 .tdm-progress-bar:after{border-color:#dc2427}.tdm-btn-style1{background-color:#dc2427}.tdm-btn-style2:before{border-color:#dc2427}.tdm-btn-style2{color:#dc2427}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #dc2427;-moz-box-shadow:0 2px 16px #dc2427;box-shadow:0 2px 16px #dc2427}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #dc2427;-moz-box-shadow:0 4px 26px #dc2427;box-shadow:0 4px 26px #dc2427}.tdm-header-style-1.td-header-wrap .td-header-top-menu-full,.tdm-header-style-1.td-header-wrap .top-header-menu .sub-menu,.tdm-header-style-2.td-header-wrap .td-header-top-menu-full,.tdm-header-style-2.td-header-wrap .top-header-menu .sub-menu,.tdm-header-style-3.td-header-wrap .td-header-top-menu-full,.tdm-header-style-3.td-header-wrap .top-header-menu .sub-menu{background-color:#020000}</style><style id="tdw-css-placeholder"></style></head><body class="post-template-default single single-post postid-1283 single-format-standard how-to-use-grep-command-in-linux-with-examples global-block-template-1 td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials"> <span class="td-social-icon-wrap"> <a target="_blank" rel="nofollow" href="https://www.facebook.com/linux4one/?modal=admin_todo_tour" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" rel="nofollow" href="https://plus.google.com/u/1/communities/103177240382810915856" title="Google+"> <i class="td-icon-font td-icon-googleplus"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" rel="nofollow" href="https://twitter.com/Linux4oneC" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div><div class="td-mobile-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-linux-container"><ul id="menu-linux" class="td-mobile-main-menu"><li id="menu-item-1252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first menu-item-1252"><a href="https://linux4one.com/">Home</a></li><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://linux4one.com/category/linux/">Linux</a></li><li id="menu-item-14" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14"><a href="https://linux4one.com/category/ubuntu/">Ubuntu</a></li><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://linux4one.com/category/centos/">CentOS</a></li><li id="menu-item-13" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13"><a href="https://linux4one.com/category/debian/">Debian</a></li><li id="menu-item-15" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-15"><a href="https://linux4one.com/category/linux-commands/">Linux Commands</a></li></ul></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://linux4one.com/"><div class="td-search-close"> <a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input"> <span>Search</span> <input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><div id="td-outer-wrap" class="td-theme-wrap"><div class="td-header-wrap tdm-header tdm-header-style-1 "><div class="td-header-menu-wrap-full td-container-wrap td_stretch_container"><div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search"><div class="td-container td-header-row td-header-main-menu"><div class="tdm-menu-btns-socials"><div class="header-search-wrap"><div class="td-search-btns-wrap"> <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a> <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://linux4one.com/"><div role="search" class="td-head-form-search-wrap"> <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-menu"> <a class="td-main-logo" href="https://linux4one.com/"> <img src="https://linux4one.com/wp-content/uploads/2018/12/logo1.png" alt="Linux4one" title="Linux4one"/> <span class="td-visual-hidden">Linux4one</span> </a></div><div class="menu-linux-container"><ul id="menu-linux-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-1252"><a href="https://linux4one.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-11"><a href="https://linux4one.com/category/linux/">Linux</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-14"><a href="https://linux4one.com/category/ubuntu/">Ubuntu</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-12"><a href="https://linux4one.com/category/centos/">CentOS</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-13"><a href="https://linux4one.com/category/debian/">Debian</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-15"><a href="https://linux4one.com/category/linux-commands/">Linux Commands</a></li></ul></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-default "><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://linux4one.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Linux Commands" class="entry-crumb" href="https://linux4one.com/category/linux-commands/">Linux Commands</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">How to Use grep Command in Linux with Examples</span></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><article id="post-1283" class="post-1283 post type-post status-publish format-standard has-post-thumbnail category-linux-commands tag-grep tag-grep-command tag-linux-commands tag-terminal" itemscope itemtype="https://schema.org/Article"><div class="td-post-header"><ul class="td-category"><li class="entry-category"><a  href="https://linux4one.com/category/linux-commands/">Linux Commands</a></li></ul><header class="td-post-title"><h1 class="entry-title">How to Use grep Command in Linux with Examples</h1><div class="td-module-meta-info"> <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2019-01-19T22:00:23+00:00" >19/01/2019</time></span></div></header></div><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Flinux4one.com%2Fhow-to-use-grep-command-in-linux-with-examples%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=How+to+Use+grep+Command+in+Linux+with+Examples&url=https%3A%2F%2Flinux4one.com%2Fhow-to-use-grep-command-in-linux-with-examples%2F&via=Linux4one"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/"><div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div><div class="td-social-but-text">Google+</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/&amp;media=https://linux4one.com/wp-content/uploads/2019/01/How-to-Use-grep-Command-in-Linux-with-Examples-1.jpg&description=How+to+Use+grep+Command+in+Linux+with+Examples"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=How to Use grep Command in Linux with Examples %0A%0A https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/&title=How to Use grep Command in Linux with Examples"><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content"><div class="td-post-featured-image"><figure><img width="750" height="350" class="entry-thumb" src="https://linux4one.com/wp-content/uploads/2019/01/How-to-Use-grep-Command-in-Linux-with-Examples-1.jpg" srcset="https://linux4one.com/wp-content/uploads/2019/01/How-to-Use-grep-Command-in-Linux-with-Examples-1.jpg 750w, https://linux4one.com/wp-content/uploads/2019/01/How-to-Use-grep-Command-in-Linux-with-Examples-1-300x140.jpg 300w" sizes="(max-width: 750px) 100vw, 750px" alt="How to Use grep Command in Linux with Examples" title="How to Use grep Command in Linux with Examples"/><figcaption class="wp-caption-text">How to Use grep Command in Linux with Examples</figcaption></figure></div><div id="toc_container" class="toc_wrap_left no_bullets"><p class="toc_title">Contents</p><ul class="toc_list"><li><a href="#Basic_Syntax_for_grep_Command"><span class="toc_number toc_depth_1">1</span> Basic Syntax for grep Command</a></li><li><a href="#Grep_command_to_find_a_particular_string_inside_the_file"><span class="toc_number toc_depth_1">2</span> Grep command to find a particular string inside the file</a></li><li><a href="#Display_Number_Of_Matching_Lines"><span class="toc_number toc_depth_1">3</span> Display Number Of Matching Lines</a></li><li><a href="#Invert_Match_in_Grep_Command"><span class="toc_number toc_depth_1">4</span> Invert Match in Grep Command</a></li><li><a href="#Recursive_Search"><span class="toc_number toc_depth_1">5</span> Recursive Search</a></li><li><a href="#Search_String_in_Standard_Output"><span class="toc_number toc_depth_1">6</span> Search String in Standard Output</a></li><li><a href="#Search_Exact_Matching_Words"><span class="toc_number toc_depth_1">7</span> Search Exact Matching Words</a></li><li><a href="#Show_Number_of_Lines_Matching"><span class="toc_number toc_depth_1">8</span> Show Number of Lines Matching</a></li><li><a href="#Conclusion"><span class="toc_number toc_depth_1">9</span> Conclusion</a></li></ul></div><h2>Use grep Command in Linux</h2><p>The grep command used to find a particular string or pattern in one or multiple patterns. Grep stands for &#8220;Global Regular Expression Print&#8221;. Grep is the most powerful command in Linux used most commonly. It can be also used to read Standard Output from another command. In this tutorial, you are going to learn how to use grep command in Linux.</p><h3><span id="Basic_Syntax_for_grep_Command">Basic Syntax for grep Command</span></h3><p>Following is the basic syntax for command <code>grep</code>.</p><pre>grep [OPTIONS] PATTERN [FILES]</pre><p>OPTIONS: <a href="https://www.gnu.org/software/grep/manual/grep.html#Command_002dline-Options">Grep options</a> are used to change the behavior of the command.</p><ul><li>-i : Used for ignoring matching case.</li><li>-c: It prints count of lines matching.</li><li>-l : Displays list of filenames.</li><li>-n : Number of matched lines and their line numbers.</li><li>-v : Number of lines that do not match the pattern.</li><li>-w : Match the whole word</li></ul><p>PATTERN: Provide the search pattern.<br /> FILE: Input file names.</p><h3><span id="Grep_command_to_find_a_particular_string_inside_the_file">Grep command to find a particular string inside the file</span></h3><p>Grep command mostly used for searching string in the file. You can also search string inside file case sensitively.</p><p>Run the command below to search a string <code>John</code> inside <code>names.txt</code> file:</p><pre>grep John names.txt</pre><p>If you want to search <code>John</code> case insensitively then run the <code>grep</code> command with <code></code> option -i .</p><pre>grep -i John names.txt</pre><p>If string you want to search includes spaces then <u>enclose</u> them inside single or double quotes. In the below example, it will search <code>John Hanks</code> in <code>names.txt</code> file.</p><pre>grep -i "John Hanks" names.txt</pre><h3><span id="Display_Number_Of_Matching_Lines">Display Number Of Matching Lines</span></h3><p>You can display number of matching lines using grep command with <code>-c</code> option. Run following command to find count of string <code>John</code> in <code>names.txt</code> file:</p><pre>grep -c John names.txt</pre><h3><span id="Invert_Match_in_Grep_Command">Invert Match in Grep Command</span></h3><p>Invert match (<code>-v</code> ) option is used to invert the grep output. The command will display the lines which do not match the given pattern.</p><p>To display the lines which do not match string <code>John</code> inside names.txt file run following command.</p><pre>grep -v John names.txt</pre><h3><span id="Recursive_Search">Recursive Search</span></h3><p>To search given string inside all the files inside a directory <code>-r</code> &#8211;recursive option is used.</p><p>In below example string &#8220;John&#8221; will be searched in all files inside <code>colleges</code> directory:</p><pre>grep -r John /Documents/colleges</pre><p>By using option <code>-R</code> you can also search symbolic link files inside directories:</p><pre>grep -R John /Documents/colleges</pre><p>To search string in all directories you can run the following command:</p><pre>grep -r "John" *</pre><h3><span id="Search_String_in_Standard_Output">Search String in Standard Output</span></h3><p>If you want to search string inside a command output, you can do so by combining grep command with another command or commands.</p><p>To find the string <code>inet6</code> inside command output of <code>ifconfig</code> run following command:</p><pre>ifconfig | grep inet6</pre><h3><span id="Search_Exact_Matching_Words">Search Exact Matching Words</span></h3><p>You can search exact matching words inside the file by using option<code>-w</code> with grep command.</p><p>By using the following command you will only get lines which contain exact word <code>John</code> inside the file:</p><pre>grep -w John names.txt</pre><h3><span id="Show_Number_of_Lines_Matching">Show Number of Lines Matching</span></h3><p>To display the count of lines matching inside a file you can use option <code>-c</code> with grep command.</p><p>For example, You can get the count of lines containing string John by running the following command.</p><pre>grep -c John names.txt</pre><p>You can also get the count of matching lines with standard output to do so run the following command.</p><pre>ifconfig | grep -c inet</pre><p>Above command will search string <code>inet</code> inside standard output provided by the command <code>ifconfig</code>.</p><h3><span id="Conclusion">Conclusion</span></h3><p>You have successfully learned how to use grep command in Linux. If you have any queries regarding this then please don’t forget to comment below.</p></div><footer><div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://linux4one.com/tag/grep/">grep</a></li><li><a href="https://linux4one.com/tag/grep-command/">grep command</a></li><li><a href="https://linux4one.com/tag/linux-commands/">linux commands</a></li><li><a href="https://linux4one.com/tag/terminal/">terminal</a></li></ul></div><div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Flinux4one.com%2Fhow-to-use-grep-command-in-linux-with-examples%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=How+to+Use+grep+Command+in+Linux+with+Examples&url=https%3A%2F%2Flinux4one.com%2Fhow-to-use-grep-command-in-linux-with-examples%2F&via=Linux4one"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/"><div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div><div class="td-social-but-text">Google+</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/&amp;media=https://linux4one.com/wp-content/uploads/2019/01/How-to-Use-grep-Command-in-Linux-with-Examples-1.jpg&description=How+to+Use+grep+Command+in+Linux+with+Examples"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=How to Use grep Command in Linux with Examples %0A%0A https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/&title=How to Use grep Command in Linux with Examples"><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div> </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://linux4one.com/how-to-use-scp-command-to-transfer-files-folders-in-linux/">How to Use SCP Command to Transfer Files/Folders in Linux</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://linux4one.com/how-to-check-centos-version/">How to Check CentOS Version</a></div></div></div><div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="">root_rahul</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="root_rahul"></span><meta itemprop="datePublished" content="2019-01-19T22:00:23+00:00"><meta itemprop="dateModified" content="2019-01-20T20:38:07+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://linux4one.com/how-to-use-grep-command-in-linux-with-examples/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://linux4one.com/wp-content/uploads/2018/12/logo1.png"></span><meta itemprop="name" content="Linux4one"></span><meta itemprop="headline " content="How to Use grep Command in Linux with Examples"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://linux4one.com/wp-content/uploads/2019/01/How-to-Use-grep-Command-in-Linux-with-Examples-1.jpg"><meta itemprop="width" content="750"><meta itemprop="height" content="350"></span></footer></article><div class="comments" id="comments"></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><div class="td_block_wrap td_block_3 td_block_widget td_uid_2_5c45eeb4c0f8f_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding"  data-td-block-uid="td_uid_2_5c45eeb4c0f8f" ><script>var block_td_uid_2_5c45eeb4c0f8f = new tdBlock();
block_td_uid_2_5c45eeb4c0f8f.id = "td_uid_2_5c45eeb4c0f8f";
block_td_uid_2_5c45eeb4c0f8f.atts = '{"custom_title":"Popular Posts","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","accent_text_color":"#","m1_tl":"","limit":"10","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"random_posts","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_2_5c45eeb4c0f8f_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m1f_title_font_header":"","m1f_title_font_title":"Article title","m1f_title_font_settings":"","m1f_title_font_family":"","m1f_title_font_size":"","m1f_title_font_line_height":"","m1f_title_font_style":"","m1f_title_font_weight":"","m1f_title_font_transform":"","m1f_title_font_spacing":"","m1f_title_":"","m1f_cat_font_title":"Article category tag","m1f_cat_font_settings":"","m1f_cat_font_family":"","m1f_cat_font_size":"","m1f_cat_font_line_height":"","m1f_cat_font_style":"","m1f_cat_font_weight":"","m1f_cat_font_transform":"","m1f_cat_font_spacing":"","m1f_cat_":"","m1f_meta_font_title":"Article meta info","m1f_meta_font_settings":"","m1f_meta_font_family":"","m1f_meta_font_size":"","m1f_meta_font_line_height":"","m1f_meta_font_style":"","m1f_meta_font_weight":"","m1f_meta_font_transform":"","m1f_meta_font_spacing":"","m1f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_2_5c45eeb4c0f8f_rand","tdc_css_class_style":"td_uid_2_5c45eeb4c0f8f_rand_style"}';
block_td_uid_2_5c45eeb4c0f8f.td_column_number = "1";
block_td_uid_2_5c45eeb4c0f8f.block_type = "td_block_3";
block_td_uid_2_5c45eeb4c0f8f.post_count = "10";
block_td_uid_2_5c45eeb4c0f8f.found_posts = "95";
block_td_uid_2_5c45eeb4c0f8f.header_color = "#";
block_td_uid_2_5c45eeb4c0f8f.ajax_pagination_infinite_stop = "";
block_td_uid_2_5c45eeb4c0f8f.max_num_pages = "10";
tdBlocksArray.push(block_td_uid_2_5c45eeb4c0f8f);</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">Popular Posts</span></h4></div><div id=td_uid_2_5c45eeb4c0f8f class="td_block_inner"><div class="td-block-span12"><div class="td_module_1 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://linux4one.com/how-to-install-webstorm-on-centos-7/" rel="bookmark" class="td-image-wrap" title="How to Install WebStorm on CentOS 7"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC"alt="How to Install WebStorm on CentOS 7" title="How to Install WebStorm on CentOS 7" data-type="image_tag" data-img-url="https://linux4one.com/wp-content/uploads/2019/01/How-to-Install-WebStorm-on-CentOS-7-324x160.jpg"  width="324" height="160" /></a></div></div><h3 class="entry-title td-module-title"><a href="https://linux4one.com/how-to-install-webstorm-on-centos-7/" rel="bookmark" title="How to Install WebStorm on CentOS 7">How to Install WebStorm on CentOS 7</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-10T10:00:25+00:00" >10/01/2019</time></span></div></div></div><div class="td-block-span12"><div class="td_module_1 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://linux4one.com/how-to-install-node-js-with-npm-on-debian-9/" rel="bookmark" class="td-image-wrap" title="How to install Node.js with npm on Debian 9"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC"alt="How to install Node.js with npm on Debian 9" title="How to install Node.js with npm on Debian 9" data-type="image_tag" data-img-url="https://linux4one.com/wp-content/uploads/2018/11/How-to-install-Node.js-with-npm-on-Debian-9-1.jpg"  width="324" height="151" /></a></div></div><h3 class="entry-title td-module-title"><a href="https://linux4one.com/how-to-install-node-js-with-npm-on-debian-9/" rel="bookmark" title="How to install Node.js with npm on Debian 9">How to install Node.js with npm on Debian 9</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-11-27T22:00:51+00:00" >27/11/2018</time></span></div></div></div><div class="td-block-span12"><div class="td_module_1 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://linux4one.com/how-to-install-node-js-with-npm-on-ubuntu-18-04/" rel="bookmark" class="td-image-wrap" title="How to install Node.js with npm on Ubuntu 18.04"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC"alt="How to install Node.js with npm on Ubuntu 18.04" title="How to install Node.js with npm on Ubuntu 18.04" data-type="image_tag" data-img-url="https://linux4one.com/wp-content/uploads/2018/11/How-to-install-Node.js-with-npm-on-Ubuntu-18.04-1.jpg"  width="324" height="151" /></a></div></div><h3 class="entry-title td-module-title"><a href="https://linux4one.com/how-to-install-node-js-with-npm-on-ubuntu-18-04/" rel="bookmark" title="How to install Node.js with npm on Ubuntu 18.04">How to install Node.js with npm on Ubuntu 18.04</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-11-26T22:00:10+00:00" >26/11/2018</time></span></div></div></div><div class="td-block-span12"><div class="td_module_1 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://linux4one.com/how-to-install-pycharm-on-centos-7/" rel="bookmark" class="td-image-wrap" title="How to Install PyCharm on CentOS 7"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC"alt="How to Install PyCharm on CentOS 7" title="How to Install PyCharm on CentOS 7" data-type="image_tag" data-img-url="https://linux4one.com/wp-content/uploads/2019/01/How-to-Install-PyCharm-on-CentOS-7-324x160.jpg"  width="324" height="160" /></a></div></div><h3 class="entry-title td-module-title"><a href="https://linux4one.com/how-to-install-pycharm-on-centos-7/" rel="bookmark" title="How to Install PyCharm on CentOS 7">How to Install PyCharm on CentOS 7</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-05T10:00:31+00:00" >05/01/2019</time></span></div></div></div><div class="td-block-span12"><div class="td_module_1 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://linux4one.com/secure-nginx-with-lets-encrypt-ssl-on-ubuntu-18-04/" rel="bookmark" class="td-image-wrap" title="Secure Nginx with Let&#8217;s Encrypt SSL on Ubuntu 18.04"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC"alt="How To Secure Nginx with Let&#039;s Encrypt SSL on Ubuntu 18.04" title="Secure Nginx with Let&#8217;s Encrypt SSL on Ubuntu 18.04" data-type="image_tag" data-img-url="https://linux4one.com/wp-content/uploads/2018/11/How-To-Secure-Nginx-with-Lets-Encrypt-SSL-on-Ubuntu-18.04.jpg"  width="324" height="151" /></a></div></div><h3 class="entry-title td-module-title"><a href="https://linux4one.com/secure-nginx-with-lets-encrypt-ssl-on-ubuntu-18-04/" rel="bookmark" title="Secure Nginx with Let&#8217;s Encrypt SSL on Ubuntu 18.04">Secure Nginx with Let&#8217;s Encrypt SSL on Ubuntu 18.04</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-11-25T20:08:49+00:00" >25/11/2018</time></span></div></div></div><div class="td-block-span12"><div class="td_module_1 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://linux4one.com/how-to-install-node-js-with-npm-on-centos-7/" rel="bookmark" class="td-image-wrap" title="How to install Node.js with npm on CentOS 7"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC"alt="How to install Node.js with npm on CentOS 7" title="How to install Node.js with npm on CentOS 7" data-type="image_tag" data-img-url="https://linux4one.com/wp-content/uploads/2018/11/How-to-install-Node.jpg"  width="324" height="151" /></a></div></div><h3 class="entry-title td-module-title"><a href="https://linux4one.com/how-to-install-node-js-with-npm-on-centos-7/" rel="bookmark" title="How to install Node.js with npm on CentOS 7">How to install Node.js with npm on CentOS 7</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-11-28T22:00:29+00:00" >28/11/2018</time></span></div></div></div><div class="td-block-span12"><div class="td_module_1 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://linux4one.com/how-to-list-users-in-linux/" rel="bookmark" class="td-image-wrap" title="How to List Users in Linux"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC"alt="How to List Users in Linux" title="How to List Users in Linux" data-type="image_tag" data-img-url="https://linux4one.com/wp-content/uploads/2018/11/How-to-List-Users-in-Linux-1.jpg"  width="324" height="151" /></a></div></div><h3 class="entry-title td-module-title"><a href="https://linux4one.com/how-to-list-users-in-linux/" rel="bookmark" title="How to List Users in Linux">How to List Users in Linux</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-11-23T22:00:30+00:00" >23/11/2018</time></span></div></div></div><div class="td-block-span12"><div class="td_module_1 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://linux4one.com/how-to-install-lemp-stack-on-ubuntu-18-04/" rel="bookmark" class="td-image-wrap" title="How to install LEMP Stack on Ubuntu 18.04"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC"alt="How to install LEMP Stack on Ubuntu 18.04" title="How to install LEMP Stack on Ubuntu 18.04" data-type="image_tag" data-img-url="https://linux4one.com/wp-content/uploads/2018/10/How-to-install-LEMP-Stack-on-Ubuntu-18.04.jpg"  width="324" height="151" /></a></div></div><h3 class="entry-title td-module-title"><a href="https://linux4one.com/how-to-install-lemp-stack-on-ubuntu-18-04/" rel="bookmark" title="How to install LEMP Stack on Ubuntu 18.04">How to install LEMP Stack on Ubuntu 18.04</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-10-03T22:00:37+00:00" >03/10/2018</time></span></div></div></div><div class="td-block-span12"><div class="td_module_1 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://linux4one.com/how-to-install-audacity-on-debian-9/" rel="bookmark" class="td-image-wrap" title="How to install Audacity on Debian 9"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC"alt="How to install Audacity on Debian 9" title="How to install Audacity on Debian 9" data-type="image_tag" data-img-url="https://linux4one.com/wp-content/uploads/2018/12/How-to-install-Audacity-on-Debian-9.jpg"  width="324" height="151" /></a></div></div><h3 class="entry-title td-module-title"><a href="https://linux4one.com/how-to-install-audacity-on-debian-9/" rel="bookmark" title="How to install Audacity on Debian 9">How to install Audacity on Debian 9</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-12-17T22:00:43+00:00" >17/12/2018</time></span></div></div></div><div class="td-block-span12"><div class="td_module_1 td_module_wrap td-animation-stack"><div class="td-module-image"><div class="td-module-thumb"><a href="https://linux4one.com/how-to-install-laravel-php-framework-with-nginx-on-debian-9/" rel="bookmark" class="td-image-wrap" title="How to install Laravel PHP Framework With Nginx on Debian 9"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC"alt="How to install Laravel PHP Framework on Debian 9" title="How to install Laravel PHP Framework With Nginx on Debian 9" data-type="image_tag" data-img-url="https://linux4one.com/wp-content/uploads/2019/01/How-to-install-Laravel-PHP-Framework-on-Debian-9-324x160.jpg"  width="324" height="160" /></a></div></div><h3 class="entry-title td-module-title"><a href="https://linux4one.com/how-to-install-laravel-php-framework-with-nginx-on-debian-9/" rel="bookmark" title="How to install Laravel PHP Framework With Nginx on Debian 9">How to install Laravel PHP Framework With Nginx on Debian 9</a></h3><div class="td-module-meta-info"> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-01-01T22:00:50+00:00" >01/01/2019</time></span></div></div></div></div></div></div></div></div></div></div><div class="td-footer-wrapper td-container-wrap td-footer-template-4 "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12"></div></div><div class="td-pb-row"><div class="td-pb-span12"><div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://linux4one.com/"><img src="https://linux4one.com/wp-content/uploads/2018/12/logo1.png" alt="Linux4one" title="Linux4one"/></a></div><div class="footer-text-wrap">© 2019 Linux4one.com | All Rights Reserved.<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#b5c6c0c5c5dac7c1f5d9dcdbc0cd81dadbd09bd6dad8"><span class="__cf_email__" data-cfemail="e3909693938c9197a38f8a8d969bd78c8d86cd808c8e">[email&#160;protected]</span></a></div></div><div class="footer-social-wrap td-social-style-2"> <span class="td-social-icon-wrap"> <a target="_blank" rel="nofollow" href="https://www.facebook.com/linux4one/?modal=admin_todo_tour" title="Facebook"> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" rel="nofollow" href="https://plus.google.com/u/1/communities/103177240382810915856" title="Google+"> <i class="td-icon-font td-icon-googleplus"></i> </a> </span> <span class="td-social-icon-wrap"> <a target="_blank" rel="nofollow" href="https://twitter.com/Linux4oneC" title="Twitter"> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-pages-container"><ul id="menu-pages" class="td-subfooter-menu"><li id="menu-item-211" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-211"><a href="https://linux4one.com/privacy-policy/">Privacy Policy</a></li><li id="menu-item-212" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-212"><a href="https://linux4one.com/contact-us/">Contact Us</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"></div></div></div></div></div> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>// List of Themes, Classes and Regular expressions
		var template_name = 'Newspaper';
		switch(template_name) {
			case 'twentyeleven' :
					var classes = ['entry-meta'];
					var regex = ' by <a(.*?)\/a>;<span class="sep"> by <\/span>';
					break;
			case 'twentyten' :
					var classes = ['entry-meta'];
					var regex = ' by <a(.*?)\/a>;<span class="meta-sep">by<\/span>';
					break;
			case 'object' :
					var classes = ['post-details', 'post'];
					var regex = ' by <span(.*?)\/span>;<p class="post-details">by';
					break;
			case 'theme-revenge' :
					var classes = ['post-entry-meta'];
					var regex = 'By <a(.*?)\/a> on';
					break;
			case 'Magnificent' :
					var classes = ['meta-info'];
					var regex = '<span>by<\/span> <a(.*?)\/a>;Posted by <a(.*?)\/a> on ';
					break;
			case 'wp-clearphoto' :
					var classes = ['meta'];
					var regex = '\\|\\s*<\/span>\\s*<span class="meta-author">\\s*<a(.*?)\/a>';
					break;
			case 'wp-clearphoto1' :
					var classes = ['meta'];
					var regex = '\\|\\s*<\/span>\\s*<span class="meta-author">\\s*<a(.*?)\/a>';
					break;
			default:
					var classes = ['entry-meta'];
					var regex = ' by <a(.*?)\/a>;<span class="sep"> by <\/span>; <span class="meta-sep">by<\/span>;<span class="meta-sep"> by <\/span>';
		}
				if (typeof classes[0] !== 'undefined' && classes[0] !== null) {
				for(var i = 0; i < classes.length; i++) {
					var elements = document.querySelectorAll('.'+classes[i]);
					for (var j = 0; j < elements.length; j++) {
						var regex_array = regex.split(";");
						for(var k = 0; k < regex_array.length; k++) {
							 if (elements[j].innerHTML.match(new RegExp(regex_array[k], "i"))) {
								 var replaced_txt = elements[j].innerHTML.replace(new RegExp(regex_array[k], "i"), '');
								 elements[j].innerHTML = replaced_txt;
							 }
						}
					}			
				}
			}</script> <script type='text/javascript'>/* <![CDATA[ */ var wpcf7 = {"apiSettings":{"root":"https:\/\/linux4one.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.1' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var copyTheCode = {"selector":"pre","settings":{"selector":"pre"},"string":{"title":"Copy to Clipboard","copy":"Copy","copied":"Copied!"}}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/copy-the-code/assets/js/copy-the-code.js?ver=1.3.1' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var tocplus = {"smooth_scroll":"1","smooth_scroll_offset":"120"}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/table-of-contents-plus/front.min.js?ver=1509' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.2' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/comment-reply.min.js?ver=5.0.3' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/wp-review/public/js/js.cookie.min.js?ver=2.1.4' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/wp-review/public/js/jquery.magnific-popup.min.js?ver=1.1.0' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/underscore.min.js?ver=1.8.3' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-includes/js/wp-util.min.js?ver=5.0.3' defer></script> <script type='text/javascript'>/* <![CDATA[ */ var wpreview = {"ajaxurl":"https:\/\/linux4one.com\/wp-admin\/admin-ajax.php","rateAllFeatures":"Please rate all features","verifiedPurchase":"(Verified purchase)"}; /* ]]> */</script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/wp-review/public/js/main.js?ver=5.1.7' defer></script> <script type='text/javascript' src='https://linux4one.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=9b2b18e69ad07d597ad9079b6a4ae65e' defer></script>  <script>(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://linux4one.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://linux4one.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();</script> <div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar"><header> <a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a><div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div></header><div class="tdw-content"><div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active"> <script>(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);</script> <textarea class="tdw-css-writer-editor td_live_css_uid_1_5c45eeb4c7c6c"></textarea><div id="td_live_css_uid_1_5c45eeb4c7c6c" class="td-code-editor"></div> <script>jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5c45eeb4c7c6c');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5c45eeb4c7c6c");
                                    window.editor.$blockScrolling = Infinity;

                                    // 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
                                    editor.getSession().setUseWrapMode(true);
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});</script> </div></div><footer> <a href="#" class="tdw-save-css">Save</a><div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div><div class="tdw-resize"></div></footer></div> <script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	s.src = !("IntersectionObserver" in w) ? "https://linux4one.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-8.15.2.min.js" : "https://linux4one.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-10.17.min.js";
	w.lazyLoadOptions = {
		elements_selector: "img",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		data_sizes: "lazy-sizes",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );
	
	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };
	
	observer.observe(b, config);
}, false);</script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1548086964 -->