Bridge Wifi to Ethernet port on Mac, same IPs as rest of network


I've got a point of sale terminal/pinpad connecting to the internet through the ethernet port on my Mac mini, which has internet sharing turned on. It works... but it takes almost 5 minutes for my POS software to talk to the terminal. It used to work perfectly and then a few days ago it just started taking it's sweet A$$ time. Nothing changed. No bloody idea. I digress.

I feel like if the pinpad was on the same network than it would fix the issue.

Tried creating a bridge via terminal. Pinpad didn't get an address, but it's using DHCP so maybe that's the issue.

Tried creating a bridge through system preferences but that killed the internet to the Mac and still didn't give access to the pinpad.

The Ethernet connection in Network Preferences is yellow and says "self-assigned IP"

Please help! Thanks a bunch.


Answers:


You can’t bridge to a client-mode Wi-Fi interface. Bridging leaves MAC addresses as-is, and APs don’t accept frames from MAC addresses that have not authenticated and associated with the AP. For two devices to both bridge frames across a Wi-Fi link, they must both implement an optional part of 802.11 known as Wireless Distribution System (WDS). macOS does not have WDS functionality.

The closest solution is to have the Mac do NAT, which is what you were already doing via Internet Sharing. You should probably troubleshoot your performance problem with your previous configuration rather than switching to bridging.