Error: No matching distribution found for pip


I am trying to install pip in my python 2.6.6, I have Oracle Linux 6

I followed the answers given at this link Link

I downloaded get-pip.py file and ran the following command

sudo python2.6 get-pip.py

However I get the following error

[[email protected] Downloads]# sudo python2.6 get-pip.py
DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
Collecting pip
  Retrying (Retry(total=4, connect=None, read=None, redirect=None)) after connection broken by 'NewConnectionError('<pip._vendor.requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x3cad210>: Failed to establish a new connection: [Errno 101] Network is unreachable',)': /simple/pip/
  Retrying (Retry(total=3, connect=None, read=None, redirect=None)) after connection broken by 'NewConnectionError('<pip._vendor.requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x3cadad0>: Failed to establish a new connection: [Errno 101] Network is unreachable',)': /simple/pip/
  Retrying (Retry(total=2, connect=None, read=None, redirect=None)) after connection broken by 'NewConnectionError('<pip._vendor.requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x3cad6d0>: Failed to establish a new connection: [Errno 101] Network is unreachable',)': /simple/pip/
  Retrying (Retry(total=1, connect=None, read=None, redirect=None)) after connection broken by 'NewConnectionError('<pip._vendor.requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x3cad790>: Failed to establish a new connection: [Errno 101] Network is unreachable',)': /simple/pip/
  Retrying (Retry(total=0, connect=None, read=None, redirect=None)) after connection broken by 'NewConnectionError('<pip._vendor.requests.packages.urllib3.connection.VerifiedHTTPSConnection object at 0x3cad110>: Failed to establish a new connection: [Errno 101] Network is unreachable',)': /simple/pip/
  Could not find a version that satisfies the requirement pip (from versions: )
No matching distribution found for pip

The error shows some network issue, but I have full open internet access here.

How can I install pip?

I also tried yum, yum install python-pip but it gave the following message

[[email protected] ~]# yum install python-pip
Loaded plugins: refresh-packagekit, security, ulninfo
Setting up Install Process
No package python-pip available.
Error: Nothing to do

Update 1:

I used the following command,

python get-pip.py --proxy="MY_PROXY"

I get the following error

DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6
    Collecting pip
    Exception:
    Traceback (most recent call last):
      File "/tmp/tmpnz7ISh/pip.zip/pip/basecommand.py", line 215, in main
        status = self.run(options, args)
      File "/tmp/tmpnz7ISh/pip.zip/pip/commands/install.py", line 324, in run
        requirement_set.prepare_files(finder)
      File "/tmp/tmpnz7ISh/pip.zip/pip/req/req_set.py", line 380, in prepare_files
        ignore_dependencies=self.ignore_dependencies))
      File "/tmp/tmpnz7ISh/pip.zip/pip/req/req_set.py", line 554, in _prepare_file
        require_hashes
      File "/tmp/tmpnz7ISh/pip.zip/pip/req/req_install.py", line 278, in populate_link
        self.link = finder.find_requirement(self, upgrade)
      File "/tmp/tmpnz7ISh/pip.zip/pip/index.py", line 465, in find_requirement
        all_candidates = self.find_all_candidates(req.name)
      File "/tmp/tmpnz7ISh/pip.zip/pip/index.py", line 423, in find_all_candidates
        for page in self._get_pages(url_locations, project_name):
      File "/tmp/tmpnz7ISh/pip.zip/pip/index.py", line 568, in _get_pages
        page = self._get_page(location)
      File "/tmp/tmpnz7ISh/pip.zip/pip/index.py", line 683, in _get_page
        return HTMLPage.get_page(link, session=self.session)
      File "/tmp/tmpnz7ISh/pip.zip/pip/index.py", line 792, in get_page
        "Cache-Control": "max-age=600",
      File "/tmp/tmpnz7ISh/pip.zip/pip/_vendor/requests/sessions.py", line 488, in get
        return self.request('GET', url, **kwargs)
      File "/tmp/tmpnz7ISh/pip.zip/pip/download.py", line 386, in request
        return super(PipSession, self).request(method, url, *args, **kwargs)
      File "/tmp/tmpnz7ISh/pip.zip/pip/_vendor/requests/sessions.py", line 475, in request
        resp = self.send(prep, **send_kwargs)
      File "/tmp/tmpnz7ISh/pip.zip/pip/_vendor/requests/sessions.py", line 596, in send
        r = adapter.send(request, **kwargs)
      File "/tmp/tmpnz7ISh/pip.zip/pip/_vendor/cachecontrol/adapter.py", line 47, in send
        resp = super(CacheControlAdapter, self).send(request, **kw)
      File "/tmp/tmpnz7ISh/pip.zip/pip/_vendor/requests/adapters.py", line 390, in send
        conn = self.get_connection(request.url, proxies)
      File "/tmp/tmpnz7ISh/pip.zip/pip/_vendor/requests/adapters.py", line 290, in get_connection
        proxy_manager = self.proxy_manager_for(proxy)
      File "/tmp/tmpnz7ISh/pip.zip/pip/_vendor/requests/adapters.py", line 184, in proxy_manager_for
        **proxy_kwargs
      File "/tmp/tmpnz7ISh/pip.zip/pip/_vendor/requests/adapters.py", line 43, in SOCKSProxyManager
        raise InvalidSchema("Missing dependencies for SOCKS support.")
    InvalidSchema: Missing dependencies for SOCKS support.

Answers:


This is a proxy issue because of using sudo. Starting a command with sudo will not ensure that exports like export http_proxy=<MY_PROXY>are still up to date.

You should try that :

python get-pip.py --proxy="[user:[email protected]]proxy.server:port"

and if you don't have user/passwd just :

python get-pip.py --proxy="proxy.server:port"

Example :

python get-pip.py --proxy="192.168.0.12:3128"