Installing vim with homebrew assistance


I tried to install YouCompleteMe on Mac for vim, but I've been using the system vim which is version 7.3. I tried to update my vim using homebrew by typing brew install vim and everything seemed to be fine.

When I type vim I still see the system vim loading (version 7.3).

I feel like I'm missing a step that's keeping me from using the updated vim I got from homebrew. Does anyone know what I'm missing?

For reference when I type which vim I get the following output /usr/bin/vim. Any help would be greatly appreciated.


Answers:


Just install vim via homebrew:

brew install vim

Then restart your shell:

exec -l $SHELL

And check the version:

$ vim --version|head -n 1
VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Mar  9 2016 19:07:39)